RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Allison Transmission Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2018, 06:22 PM   #1
Junior Member
 
Join Date: Feb 2018
Posts: 7
Shift inhibit and trans light on

At the end of our last trip while backing motorhome in the driveway, it started to jerk in reverse. Engine would rev and then would catch and unit would move. Been sitting for a couple weeks now and I tried to move it and get the trans light when started and if I try to shift into reverse shift inhibit light comes on. Wont move in drive either. Checked fluid and it seems to be way up the dipstick. Anybody have any ideas where to start. MH is a 2003 Damon Intruder with the 8 liter engine and Allison 1000 transmission. 65000 miles on unit. Looking for help. Dont know where to start.
__________________

__________________
2003 Damon Intuder 350
canuck13 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-04-2018, 07:30 AM   #2
Senior Member
 
geofferyh's Avatar
 
Join Date: Feb 2011
Posts: 138
I have a 2003 Holiday Rambler Admiral with 8.1L and Allison 1000 with 66,000 miles. It gets driven between Michigan and Florida each April and November only. Has performed without incident thus far.
__________________

__________________
Jeffery
2003 Holiday Rambler Admiral SE W22 8.1L
Summer in Michigan, Winter in Panama City, FL
geofferyh is offline   Reply With Quote
Old 10-04-2018, 01:20 PM   #3
Senior Member
 
Join Date: Apr 2009
Posts: 398
Quote:
Originally Posted by canuck13 View Post
At the end of our last trip while backing motorhome in the driveway, it started to jerk in reverse. Engine would rev and then would catch and unit would move. Been sitting for a couple weeks now and I tried to move it and get the trans light when started and if I try to shift into reverse shift inhibit light comes on. Wont move in drive either. Checked fluid and it seems to be way up the dipstick. Anybody have any ideas where to start. MH is a 2003 Damon Intruder with the 8 liter engine and Allison 1000 transmission. 65000 miles on unit. Looking for help. Dont know where to start.
1. Are you checking the fluid with the engine running or is the engine shut off?
2. Is the fluid a nice translucent red and you can see the stick underneath, or is the fluid milky like a strawberry color, or is the fluid black?
dbarton291 is offline   Reply With Quote
Old 10-04-2018, 01:30 PM   #4
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 7,454
It came with Dexron iii which was supposed to be changed every 25,000 miles or 2 years.

The spin on filter was supposed to be changed at 5,000 miles.

Have you ever changed them.


I've changed mine myself over the years and last year went to Transynd. I change the spin on filter every time too.
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS

Don't know where I'm going, spose I'll get there anyway.
Arch Hoagland is offline   Reply With Quote
Old 10-05-2018, 04:10 AM   #5
Junior Member
 
Join Date: Feb 2018
Posts: 7
Oil was checked cold. And I have only had this unit for a year so no I havent changed the filter yet. Oil looks normal. not milky or watery. I disconnect negative cable for a bit and now its reset. Hopefully be able to get it in for service now
__________________
2003 Damon Intuder 350
canuck13 is offline   Reply With Quote
Old 10-09-2018, 09:15 PM   #6
Senior Member
 
terry735001's Avatar
 
Join Date: Sep 2012
Posts: 1,176
Blog Entries: 11
sheft sensor on side of trans . just a guess but giving it started after you put it in R and now if its the Transmission Range Sensor or called some 4 letter word NS??


is the dash showing what gear you move it into
terry735001 is offline   Reply With Quote
Old 10-09-2018, 10:09 PM   #7
Senior Member
 
Join Date: Apr 2009
Posts: 398
Quote:
Originally Posted by terry735001 View Post
sheft sensor on side of trans . just a guess but giving it started after you put it in R and now if its the Transmission Range Sensor or called some 4 letter word NS??


is the dash showing what gear you move it into
NSBU switch?
dbarton291 is offline   Reply With Quote
Old 10-15-2018, 12:47 AM   #8
Junior Member
 
Join Date: Jul 2018
Posts: 7
My NSBU Switch had moisture and corrosion - similar symptoms.
Attached Thumbnails
Click image for larger version

Name:	NSBU unit.jpg
Views:	28
Size:	143.2 KB
ID:	222607  
__________________

iluvspd is offline   Reply With Quote
Reply

Tags
light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shift Inhibit 2006 Fleetwood Providence 39s 3000MH markmarchido Allison Transmission Forum 1 09-05-2016 09:51 PM
"Shift Inhibit" light in Winnebago Journey donnariley53 Winnebago Industries Owner's Forum 17 10-12-2014 06:28 PM
shift inhibit indicator? esetter3391 MH-General Discussions & Problems 4 03-16-2012 03:09 PM
W-22 Allison 1000 Shift Inhibit hwybnb Workhorse and Chevrolet Chassis Motorhome Forum 6 03-07-2006 06:40 AM
Shift Inhibit? and shakedown issues rockcj Alpine Coach Owner's Forum 24 06-29-2005 09:54 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.