RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Allison Transmission Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-19-2019, 06:03 PM   #1
Junior Member
 
SGraham's Avatar
 
Rexhall Owners Group
Join Date: Mar 2017
Posts: 7
Shift pad issue

Not sure if this has been covered but here goes. After the coach was parked for an extended period of time and after replacing the chassis batteries, when I turn the key switch to start nothing happens. I have noticed that the Mode light on the shift pad is lit and the pad does not change when buttons are pushed. Any thoughts on what this could be?
__________________

SGraham is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-19-2019, 06:33 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 17,313
The mode light is lit or not lit ?

If not lit, the transmission control power wire goes to the battery. Make sure the + and - wires are on the batteries.

Buried in the harness is a fuse that gets pulled apart when pulling on the cables. Happen many times on this site.
__________________

twinboat is offline   Reply With Quote
Old 03-20-2019, 05:28 AM   #3
Junior Member
 
SGraham's Avatar
 
Rexhall Owners Group
Join Date: Mar 2017
Posts: 7
The mode light is lit and won’t go off. Engine won’t start. No other display on the shift pad.
SGraham is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shift or Not to Shift BigAWB Class A Motorhome Discussions 30 09-05-2014 06:47 PM
2001 Knight - No electric to shift pad & ignition DennyAA Monaco Owner's Forum 2 10-29-2013 08:28 AM
Shift Pad Placement SueMac Monaco Owner's Forum 2 02-07-2012 12:30 PM
Allison shift pad 94 HR Navigator wglasson Class A Motorhome Discussions 10 12-26-2011 06:53 AM
To shift or not to shift Rick A Trailer Towing and Tow Vehicles Discussion 16 03-26-2007 01:04 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.