Go Back   iRV2 Forums > TRUCK CONVERSIONS, MDT's & HDT's FORUMS > MDT Conversions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 10-28-2010, 06:11 PM   #1
Senior Member
Join Date: Dec 2009
Location: Welches, Oregon
Posts: 732
Brake lights

I have a Sport Chassis M2 with a Mercedes MBE 900 engine. My problem is that all the tail lights work, but when I hook it up to my 5th wheel, I have no left brake light. Both turn signals work. Here is what I found. At the junction box at the back of my truck, I have correct voltage (13) except for the left stop light that shows 1 volt. The truck left side comes on, but, I think because it LED's low voltage would turn the lights on. I'm sure it's the truck and not the trailer. The voltage has been checked with the trailer unhooked. Any ideas?

RWeigant is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-28-2010, 08:01 PM   #2
Senior Member
Join Date: Apr 2010
Posts: 689
Has to be on the truck side. I would start tracing wire forward with volt meter

RVhauler is offline   Reply With Quote
Old 10-29-2010, 05:44 PM   #3
Senior Member
Join Date: Dec 2009
Location: Welches, Oregon
Posts: 732
I found the problem. Under the truck between the two cab door is a fuse box hidden on the left side. There is four 20 amp fuses there and wouldn't you know the last one I checked was the bad one. It's a bitch to get to, but, it's over. Saved $200.
RWeigant is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Find MH Fuses for Brake Lights and Turn Signals rsalhus MH-General Discussions & Problems 6 12-16-2009 02:55 AM
No brake lights DBish MH-General Discussions & Problems 2 06-28-2009 02:14 PM
Brake Lights flash with TOAD attached CDR Dave Alpine Coach Owner's Forum 5 10-07-2008 07:06 PM
Jake Brake Lights? leavitt Newmar Owner's Forum 13 11-25-2007 04:26 PM
No brake lights Qmaster MH-General Discussions & Problems 4 10-31-2006 02:53 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:06 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.