RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-03-2015, 08:24 AM   #1
Senior Member
 
macantic's Avatar
 
Join Date: Feb 2012
Location: Aiken,SC
Posts: 1,025
1988 Georgieboy Charging Problem

has a new alternator that puts out 14.4 volts but is not charging the battery,is there a fuse,relay or solenoid somewhere that keeps it from charging the battery? Thanks,
__________________

__________________
Good Sam Life Members
Served in U.S.A.F.
macantic is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-05-2015, 08:37 PM   #2
Member
 
ssimmons's Avatar
 
Join Date: Apr 2015
Location: Moncks Corner, sc
Posts: 38
What engine you have?
__________________

ssimmons is offline   Reply With Quote
Old 06-05-2015, 10:08 PM   #3
Senior Member
 
macantic's Avatar
 
Join Date: Feb 2012
Location: Aiken,SC
Posts: 1,025
Quote:
Originally Posted by ssimmons View Post
What engine you have?
454 chevy
__________________
Good Sam Life Members
Served in U.S.A.F.
macantic is offline   Reply With Quote
Old 06-06-2015, 10:20 AM   #4
Member
 
ssimmons's Avatar
 
Join Date: Apr 2015
Location: Moncks Corner, sc
Posts: 38
Check to make sure that the big red wire from the back of the alternator going to the battery or starter has not lost it's connection.
ssimmons is offline   Reply With Quote
Old 06-06-2015, 10:33 AM   #5
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by macantic View Post
has a new alternator that puts out 14.4 volts but is not charging the battery, is there a fuse,relay or solenoid somewhere that keeps it from charging the battery? Thanks,
macantic
A bad diode in your solid state battery isolator, (if there is a solid state isolator in your charging system), will cause that.
Mel
'96 Safari
mel s is offline   Reply With Quote
Reply

Tags
charging



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1988 georgieboy charging problem macantic Class A Motorhome Discussions 4 06-02-2015 08:32 AM
Help! Battery not charging? Boomster Travel Trailer Discussion 2 05-31-2015 10:44 AM
2007 Winnebago View Charging Solenoid Pics ko4nrbs RV Systems & Appliances 3 10-10-2014 06:04 PM
Dinghy Battery Charging bunnb1 Monaco Owner's Forum 1 07-17-2014 08:34 PM
Charging problem Riverratt MH-General Discussions & Problems 6 03-22-2014 08:29 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×