RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2019, 01:49 PM   #1
Junior Member
 
Join Date: Sep 2019
Posts: 18
2003 W22 all dash lights on

Hi all. I have a 2003 Winnebago Adventurer (8.1). My start battery was low today so I used the house battery boost to start the engine. After that, all the dash warning lights stay on while engine is running. Turned the key to off position and removed key, still all lights are on. What's going on? Do you have experienced this also at some time?
Thanks. Fritz
__________________

frnu is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-09-2019, 03:27 PM   #2
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 9,175
Never had the dash lights stay on.

Have you disconnected the engine battery and, if so, did the dash lights go out?
__________________

__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS

Don't know where I'm going, spose I'll get there anyway.
Arch Hoagland is offline   Reply With Quote
Old 12-09-2019, 05:32 PM   #3
Junior Member
 
Join Date: Sep 2019
Posts: 18
That's my next step. Will try it tomorrow. Hope I don't have to replace the instrument cluster.
frnu is offline   Reply With Quote
Old 12-10-2019, 08:22 PM   #4
Senior Member
 
CJ7365's Avatar
 
Tiffin Owners Club
Join Date: Mar 2015
Location: Southern NM
Posts: 2,244
I would also check your battery connections, and inspect/clean grounding points.
__________________
2005 Tiffin Allegro Bay 37DB
W22 Workhorse Chassis 8.1 Flat Towing a 82 Jeep CJ7
CJ7365 is offline   Reply With Quote
Old 12-12-2019, 01:03 PM   #5
Junior Member
 
Join Date: Sep 2019
Posts: 18
Thanks for your help. The dash lights are off now after disconnecting the Battery. Charged the battery and reconnected, no more lights. Started right up but now I have a dead miss and I cannot rev the engine up over 3000 RPM, like it has a limit there. Maybe needs to go back to shop. Had a tune-up done a couple of months ago with AC-Delco plugs and extreme wires from Brazels.
frnu is offline   Reply With Quote
Old 12-12-2019, 02:24 PM   #6
Senior Member
Official iRV2 Sponsor
 
Join Date: Jul 2005
Location: CENTRALIA, WA
Posts: 1,460
Quote:
Originally Posted by frnu View Post
Started right up but now I have a dead miss and I cannot rev the engine up over 3000 RPM, like it has a limit there. Maybe needs to go back to shop.

There is a 3,000 rpm rev limiter in park or neutral, that is normal.
__________________
Jon Brazel
Ultra RV Products / Brazel's RV Performance
Ultra RV Products is offline   Reply With Quote
Old 12-13-2019, 05:53 AM   #7
Junior Member
 
Join Date: Sep 2019
Posts: 18
Thank you Jon Brazel for your quick response. Will check the fuel pressure today to eliminate a possible issue there when it comes to the miss. If that's not the problem, I'll have to bring it back to the shop.
frnu is offline   Reply With Quote
Old 12-13-2019, 11:42 AM   #8
Senior Member
 
vettenuts's Avatar
 
Join Date: Nov 2013
Posts: 4,444
Did it miss prior to the dash light issue? Wondering if it’s just one plug wire not installed correctly.
__________________
2005 Newmar Kountry Star 3742 - Gas
2018 Chevrolet Colorado Toad
Roadmaster Tow Setup
vettenuts is offline   Reply With Quote
Old 12-13-2019, 01:00 PM   #9
Junior Member
 
Join Date: Sep 2019
Posts: 18
no miss before, only warm start issue. Happened after the dash light issue. Had a dad battery and started it with battery boost switch. After I turned the engine off, all lights came on. Have a new battery now and the lights are out. It's missing bad, can hardly keep it idling. Had the Magnum Extreme and AC Delco installed at a reputable shop about 2 months ago but hardly drove it since.
frnu is offline   Reply With Quote
Old 12-13-2019, 01:05 PM   #10
Senior Member
 
cavie's Avatar
 
Join Date: Jul 2018
Posts: 2,213
Have you computer codes read. Sounds like the BCM may be out. Had that happen with my 2004 buick.
__________________
2011 Keystone Sprinter 323 BHS. Port Charlotte Fl/Hinsdale MA. Retired Master Electrician. All Motor homes are RV's. All RV's are not Motor homes.
cavie is online now   Reply With Quote
Old 12-13-2019, 02:40 PM   #11
Junior Member
 
Join Date: Sep 2019
Posts: 18
Thanks cavie. If the BCM would be out, would that make the engine have a miss fire? And how can I find out if the BCM is out?
frnu is offline   Reply With Quote
Old 12-14-2019, 06:39 AM   #12
Senior Member
 
vettenuts's Avatar
 
Join Date: Nov 2013
Posts: 4,444
Think I would look at the simple free things first. Fuel pressure, check the MAF and air filter (my daughter’s car had a mouse chew up the air filter and there were lots of little filter pieces in the filter housing).


An error code should turn on the check engine light, which should actually be flashing if there’s a miss. Is the check engine light on?

Note, you can rent for free many of the tools from Autozone needed to check things out. I carry a little device called Blue Driver that plugs into the OBD II port and communicates with a phone app.
__________________
2005 Newmar Kountry Star 3742 - Gas
2018 Chevrolet Colorado Toad
Roadmaster Tow Setup
vettenuts is offline   Reply With Quote
Old 12-14-2019, 08:46 AM   #13
Junior Member
 
Join Date: Sep 2019
Posts: 18
Thank you vettenuts. I'll check the fuel pressure first since I always have a warm start problem to make sure no leaks into the manifold or cylinders. I will check for all wire connections incl. the new plug wires, check for vacuum leaks also. Then I will go to Autozone to read the ECU for codes. I do not have a check engine light on. I will probably buy a Scangauge II or the Ultraqauge, don't know which one yet. I will keep the posts coming.
frnu is offline   Reply With Quote
Old 12-14-2019, 09:00 AM   #14
Senior Member
 
vettenuts's Avatar
 
Join Date: Nov 2013
Posts: 4,444
If the fuel pressure is dropping after shutdown, it can also be an injector leaking. There is tester for injector leak down testing for future reference.

I bought an injector tester years ago to chase an intermittent miss in my car. In the end it was the computer and you could see the ground signal dropping out for some of the injectors.
__________________

__________________
2005 Newmar Kountry Star 3742 - Gas
2018 Chevrolet Colorado Toad
Roadmaster Tow Setup
vettenuts is offline   Reply With Quote
Reply

Tags
dash, light, lights, w22



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash lights, running lights and brake lights are intermittent! flyr4u Monaco Owner's Forum 8 05-27-2019 07:32 AM
W22 Dash Warning Lights Kxbronco Workhorse and Chevrolet Chassis Motorhome Forum 7 05-03-2019 09:28 AM
Problem with tail-lights, dash lights, clearance lights...2001 Intrigue daryl989mich Country Coach Owners Forum 3 08-01-2018 12:19 PM
All Tank Monitor readings have all LED lights lit and cannot find source of problem?? Philliec Monaco Owner's Forum 3 09-03-2017 10:57 PM
No tail lights, brake lights, 2003 Mountain Aire kwseeger Spartan Motorhome Chassis Forum 6 12-19-2014 08:45 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×