Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2017, 11:59 AM   #1
Member
 
mjlayton's Avatar
 
Join Date: Jan 2012
Posts: 32
'96 P30 National Dolphin Oil Sender

When the engine is well warmed at an idle, the oil pressure has short pulses lower on the gauge. It is quick with irregular timing. The gauge indicate around 30 P.S.I. My mechanic thinks the sending unit may be going bad. I've looked over the engine many times and cannot find it. It is not above the oil filter as many on-line photos show. I'm sure most late 90s P30 chassis' are all in the same place. Any ideas.

Thanks,
Mike Layton
__________________

__________________
mjlayton is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-20-2017, 03:14 PM   #2
Member
 
mjlayton's Avatar
 
Join Date: Jan 2012
Posts: 32
found it

Going to attach a phot I found on the internet because it clearly shows location. I could barely see the one on my motorhome fuel lines, wiring bundles, and etc. made it impossible to photograph mine.




FYI; It's the tall black cylinder just below the right blue fitting, ahead of the bell housing
Attached Thumbnails
Click image for larger version

Name:	DSC04990.jpg
Views:	22
Size:	279.8 KB
ID:	155454  
__________________
mjlayton is offline   Reply With Quote
Reply

Tags
dolphin, national, p30



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dolphin :: 2007 National RV 2007 Dolphin Jim1950 iRV2 Owners Registry 0 10-19-2016 11:37 AM
Correct oil capacity (with filter) and oil pressure (operating) of a 454 in a P30 ?? Peacekeeper6 Class A Motorhome Discussions 3 09-03-2015 08:16 PM
Oil pressure sender rmmpe Cummins Engines 5 10-11-2008 02:37 PM
Oil Sender Replacement MH-General Discussions & Problems 1 08-31-2005 03:31 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.