RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-12-2014, 07:04 PM   #1
Registered User
 
fun 33V's Avatar
 
Join Date: Oct 2010
Location: blank
Posts: 139
Changing brake fluid

Had good weather today changed the brake fluid & installed the speed bleeders I got from Omey, I'm getting abs light & buzzer took it for a test drive brakes seem fine cycled things on and off about 4 times but still won't turn off I am getting what looks like BRAKE Failure on the actia plugged in a code reader it says no codes. any suggestions? thanks in advance.
__________________

__________________
2005 Itasca 33V Sunrise 8.1 Workhorse W-20
fun 33V is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-12-2014, 08:25 PM   #2
iRV2 Marketing
 
DriVer's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Coastal Campers
Carolina Campers
Join Date: Jan 2000
Location: Conway, SC
Posts: 23,493
Blog Entries: 70
Quote:
Originally Posted by fun 33V View Post
Had good weather today changed the brake fluid & installed the speed bleeders I got from Omey, I'm getting abs light & buzzer took it for a test drive brakes seem fine cycled things on and off about 4 times but still won't turn off I am getting what looks like BRAKE Failure on the actia plugged in a code reader it says no codes. any suggestions? thanks in advance.
There's a pressure differential switch on the master cylinder. Just disconnect the plug off of that sensor and check to see if the ABS light goes out.

The Pressure Differential Switch is on the booster itself and not on the fluid tank.

It's possible that the switch is stuck. Good thing is that you really don't need it anyway. Newer model Hydro-Max boosters no longer support the switch and it's not connected.
.
Attached Thumbnails
Click image for larger version

Name:	Switch.JPG
Views:	60
Size:	33.9 KB
ID:	60479  
__________________

__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Old 04-12-2014, 09:15 PM   #3
Registered User
 
fun 33V's Avatar
 
Join Date: Oct 2010
Location: blank
Posts: 139
Thanks DriVer

Thanks DriVer I will Do that you are the man
__________________
2005 Itasca 33V Sunrise 8.1 Workhorse W-20
fun 33V is offline   Reply With Quote
Old 04-12-2014, 09:17 PM   #4
iRV2 Marketing
 
DriVer's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Coastal Campers
Carolina Campers
Join Date: Jan 2000
Location: Conway, SC
Posts: 23,493
Blog Entries: 70
Quote:
Originally Posted by fun 33V View Post
Thanks DriVer I will Do that you are the man
Hope it works for you! It worked for me.
__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Old 04-12-2014, 09:39 PM   #5
Registered User
 
fun 33V's Avatar
 
Join Date: Oct 2010
Location: blank
Posts: 139
switch

DriVer when I unplug the switch the light & buzzer go out I wait a couple of minutes and plug back in and the light & buzzer return just leave it unplugged?
__________________
2005 Itasca 33V Sunrise 8.1 Workhorse W-20
fun 33V is offline   Reply With Quote
Old 04-12-2014, 09:56 PM   #6
iRV2 Marketing
 
DriVer's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Coastal Campers
Carolina Campers
Join Date: Jan 2000
Location: Conway, SC
Posts: 23,493
Blog Entries: 70
Quote:
Originally Posted by fun 33V View Post
DriVer when I unplug the switch the light & buzzer go out I wait a couple of minutes and plug back in and the light & buzzer return just leave it unplugged?
Like my Air Force friends say, "Roger That!" You're not going to miss having that differential switch. Mine remains disconnected since 2010.
__________________

__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Reply

Tags
fluid, brake



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Okay ... I SOLVED THE AUTO PARK BRAKE PROBLEM! JerryPeck Workhorse and Chevrolet Chassis Motorhome Forum 167 05-29-2019 10:37 PM
ATF fluid service on E40D/4R100 questions chucksel Ford Motorhome Chassis Forum 40 10-23-2015 10:12 AM
Brake Fluid Flush, Synthetic? ronspradley MH-General Discussions & Problems 7 04-06-2014 11:35 AM
Time to flush my brake lines. How much fluid? jprisbe Ford Motorhome Chassis Forum 14 04-06-2014 06:42 AM
Hydraulic brake fluid RanchoT Class A Motorhome Discussions 2 08-17-2013 11:54 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×