RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-23-2018, 06:05 AM   #1
Member
 
Join Date: Jan 2017
Posts: 87
Chevy 454

I have a older MH with a fairly new 454 chevy engine (16000 miles). The problem is after about 2 hrs driving down the road when I get off at an exit or come to a stop sign it dies. No power steering and no power brakes is not a good feeling! I can put it in neutral and it will start and everything is fine. The motor does not show that it is hot. I have had the fuel pump replaced, ICV replaced and it does not show any codes. Any ideas? My mechanic has no idea whats wrong, drive it 10-20 miles no problem. Running out of parts to replace. Getting ready for a 10 hr trip got to get it fixed. Thanks
__________________

__________________
1992 Winnebago Adventure 34 RQ
REDEYE50 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-23-2018, 06:55 AM   #2
Senior Member
 
tomwalt's Avatar
 
Tiffin Owners Club
Workhorse Chassis Owner
Join Date: Dec 2010
Location: Northern Virginia
Posts: 1,444
I don't know but will offer some ideas. I would pull a few plugs and check their condition for rich or lean.
I assume it is fuel injected and the fuel rail pressure was within specs and fuel filter was replaced. Did this start right after the motor swap or fuel pump replacement? If so, are the original input manifold/fuel components retained (so computers are still controlling the original components)?

If carb, vacuum hoses would be a place to look.
I had carburetor bolts loosen up one time and when I stopped the carb would rock forward - the car would die, carb went back in place and it started/ran nice until the next quick stop. Took me a month until I accidentally leaned on the air filter and noticed it moved.
__________________

__________________
Tom and Amy from Northern Virginia.
2000 Allegro 454/Workhorse P32/TST/Crossfire
Life is a DIY project, so own less and live more
tomwalt is offline   Reply With Quote
Old 09-23-2018, 07:48 AM   #3
Senior Member
 
Join Date: Mar 2013
Posts: 429
What year? Carb or injection? Does it stumble or just shut off clean? Does it keep running after the first stall. The more info the better chance of getting help.
MotorPro is offline   Reply With Quote
Old 09-23-2018, 07:52 AM   #4
Senior Member
 
Join Date: Oct 2014
Location: Cypress River Manitoba
Posts: 207
My 1987 454 did that stall at the red light thing. Turned out to be a bad float in the carb and would flood at idle.
Stan
__________________
2004 Itasca Sunrise W22 chassis GM 8.1 Allison 1000 Towing a 2007 Chevy Cobalt four wheels down.
Switchflicke is offline   Reply With Quote
Old 09-23-2018, 07:53 AM   #5
Senior Member
 
Join Date: Apr 2018
Location: North Central Florida
Posts: 417
Is the idle set too low? Can you keep it running by tapping the gas pedal?

Also, maybe a vacuum leak associated with braking?
Brob is offline   Reply With Quote
Old 09-23-2018, 08:09 AM   #6
Senior Member
 
Join Date: Jan 2015
Location: SC
Posts: 103
Quote:
Originally Posted by REDEYE50 View Post
I have a older MH with a fairly new 454 chevy engine (16000 miles). The problem is after about 2 hrs driving down the road when I get off at an exit or come to a stop sign it dies. No power steering and no power brakes is not a good feeling! I can put it in neutral and it will start and everything is fine. The motor does not show that it is hot. I have had the fuel pump replaced, ICV replaced and it does not show any codes. Any ideas? My mechanic has no idea whats wrong, drive it 10-20 miles no problem. Running out of parts to replace. Getting ready for a 10 hr trip got to get it fixed. Thanks
I would think you might have bad gas, some water in it, or you using premium fuel, if not fill with premium with an octane adative. Something simple to try.
__________________
1998 National Tradewinds DP
112,000 miles
Pushed by 2010 Chev HHR
Alphuse is offline   Reply With Quote
Old 09-23-2018, 08:38 AM   #7
Member
 
Join Date: Jan 2017
Posts: 87
Quote:
Originally Posted by Alphuse View Post
I would think you might have bad gas, some water in it, or you using premium fuel, if not fill with premium with an octane adative. Something simple to try.
THANKS DONT THINK IT IS BAD FUEL. filled up several times have filled up several times and changed fuel filter
__________________
1992 Winnebago Adventure 34 RQ
REDEYE50 is offline   Reply With Quote
Old 09-23-2018, 08:40 AM   #8
Member
 
Join Date: Jan 2017
Posts: 87
Quote:
Originally Posted by Brob View Post
Is the idle set too low? Can you keep it running by tapping the gas pedal?

Also, maybe a vacuum leak associated with braking?
idles just fine
__________________
1992 Winnebago Adventure 34 RQ
REDEYE50 is offline   Reply With Quote
Old 09-23-2018, 08:42 AM   #9
Member
 
Join Date: Jan 2017
Posts: 87
Quote:
Originally Posted by MotorPro View Post
What year? Carb or injection? Does it stumble or just shut off clean? Does it keep running after the first stall. The more info the better chance of getting help.
MH is a 1992 en
gine replaced about 2yrs ago by previous owner. New crate motor
__________________
1992 Winnebago Adventure 34 RQ
REDEYE50 is offline   Reply With Quote
Old 09-23-2018, 08:43 AM   #10
Member
 
Join Date: Jan 2017
Posts: 87
Quote:
Originally Posted by MotorPro View Post
What year? Carb or injection? Does it stumble or just shut off clean? Does it keep running after the first stall. The more info the better chance of getting help.
throttle body injection
__________________
1992 Winnebago Adventure 34 RQ
REDEYE50 is offline   Reply With Quote
Old 09-24-2018, 08:52 PM   #11
BEC
Member
 
BEC's Avatar
 
Join Date: Jun 2013
Posts: 60
Quote:
Originally Posted by REDEYE50 View Post
I have a older MH with a fairly new 454 chevy engine (16000 miles). The problem is after about 2 hrs driving down the road when I get off at an exit or come to a stop sign it dies. No power steering and no power brakes is not a good feeling! I can put it in neutral and it will start and everything is fine. The motor does not show that it is hot. I have had the fuel pump replaced, ICV replaced and it does not show any codes. Any ideas? My mechanic has no idea whats wrong, drive it 10-20 miles no problem. Running out of parts to replace. Getting ready for a 10 hr trip got to get it fixed. Thanks


I don’t know what model you have. I had 2007 Allegro with Chev V8 and even with replacing the air filter on schedule the sensors inside the filter box were dirty and after a period of dying it finally wouldn’t restart. Not sure applies to you but I would check.
BEC is offline   Reply With Quote
Old 09-24-2018, 09:35 PM   #12
Senior Member
 
bob caldwell's Avatar


 
Join Date: May 2017
Location: Vancouver Wash
Posts: 4,609
You could add a rubber hose between the throttle body and the steel return line, or trace the line back to find the hose and squeeze it shut with vice grips to see if the system is retaining pressure...can also use a timing light to watch the action of the two injectors to see what pattern they are producing......they pulsate as they deliver fuel...U Tube has several videos on these.....i would also think the regulator might be dying
__________________
2010 Rockwood Sig Ultra lite 5er 8280......'99 Ram 2500, Cummins. 4x4.....Pullrite Superglide.......Use to work in calender factory.....got fired for tak'n a few days off.....
bob caldwell is offline   Reply With Quote
Old 09-24-2018, 11:30 PM   #13
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 7,798
If you put it in neutral just before stopping will it continue to run?

Keep us posted on what you find. That's gotta be irritating.
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS

Don't know where I'm going, spose I'll get there anyway.
Arch Hoagland is offline   Reply With Quote
Old 09-24-2018, 11:31 PM   #14
Senior Member
 
VanDiemen23's Avatar
 
Join Date: Oct 2010
Posts: 1,085
electrical? circuit opens under deceleration, shuts off engine.
__________________

VanDiemen23 is offline   Reply With Quote
Reply

Tags
454, chevy



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1988 Holiday Rambler Chevy 454 Chevy ECM? wajell Vintage RV's 4 05-07-2016 09:31 PM
1998 Airstream on Chevy chasis /454 Louie De Carolis Class A Motorhome Discussions 8 04-28-2008 07:06 AM
1990 bounder chevy 454 Can't get 12volt lights on joe1 MH-General Discussions & Problems 5 03-18-2008 08:08 PM
86 chevy 454 operating temp chuck7 MH-General Discussions & Problems 5 09-24-2007 06:44 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.