RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-02-2015, 05:16 PM   #1
Junior Member
 
Join Date: May 2011
Location: Blue Ridge,Ga
Posts: 4
Check Gauge Light

I have 06 Fleetwood Bounder F53. We have been in campground since June last night check gauges light on dash came on ignition was not on there also was a clicking sound behind gauges. Only thing that would make it stop was pulling fuse #4 it controlled instrument panel cluster. Has anybody had this problem would like any info about this if possible

Thanks in advance
Jay Stump
__________________

Iggybus is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-02-2015, 10:04 PM   #2
Senior Member
 
grtharris's Avatar


 
Winnebago Owners Club
Join Date: Apr 2003
Location: Skiatook, OK
Posts: 2,392
A couple of other people have had the same problem but no fix. I would suspect a low chassis battery or if you are charging the chassis maybe a noisy charger.

Check Gauges
__________________
Grant & Pat
2014 Adventurer 35P
2012 Jeep Wrangler Rubicon
grtharris is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine light on 8.1 Workhorse no apparent reason Auzboy Workhorse and Chevrolet Chassis Motorhome Forum 31 09-30-2014 11:59 PM
False Check Engine light on C7?? Freightguy Caterpillar Engine Forum 26 09-15-2014 09:53 AM
ECU coolant and check engine light jeffwit Freightliner Motorhome Chassis Forum 1 09-10-2014 09:40 PM
W20D with intermittent check engine light Denniscw Workhorse and Chevrolet Chassis Motorhome Forum 2 07-29-2014 12:33 PM
Check engine light and fault code budwilson Caterpillar Engine Forum 16 06-23-2014 08:05 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.