RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-21-2014, 06:55 PM   #1
Junior Member
 
Join Date: Mar 2014
Location: newport beach, ca
Posts: 4
f53 with newer pfs48 fuel pump needs pump only model #

If you could help me out with something others may find useful but I haven't been able to figure out yet. I'm trying to find out what the replacement "pump only" is that goes in a motorcraft PFS-48 "turbine style" Fuel pump assembly. All I can find is info for pumps that are stock replacements and require that I have my old stock module which was replaced 10 years ago.

Here is the problems I'm having and why I want to replace the pump:

Here goes, I have a 1994 (1994 chassis) f53 460 cu allegro bay 34' class A. 53k miles.
I am getting slightly rough idle when cold (almost perfect when warmed up) a p172 (lean code) and hesitation getting up to speed over 1/2 throttle and a major loss of power at wot after a couple seconds such as getting on the freeway or going up hills. Sometimes this is really bad and sometimes the rv runs almost perfect. Fuel pressure is about 28-30 at idle and 30-32 at wot with a steady drop to about 27psi over about 7-10 seconds wot. The fuel pump assembly was replaced in 2005 (10k miles ago) with the new style pfs-48 ford turbine pump assembly. I want to just replace the pump only in this module and can't find any info on what pump is used in the new style pump. Airtex said the e2521 would work but I'm not sure if they are assuming its the stock pump module even though I explained the difference. Have you checked on what the new pump only # is? Is it likely that the pump has died over 10 years and 10k miles or would you suspect a fuel screen clog, pressure reg, egr, iac? My iac sometimes makes a fog horn noise at idle or coasting in idle (check engine light comes on when this sound comes on but sometimes check engine light comes on with no fog horn noise but always when I let off the gas is when cel illuminates...If I drive around town very light on throttle I usually won't throw a 172 code. I imagine I may need a new IAC but could this cause my lean condition and symptoms (my fuel pressure guage is a cheapy borrowed from autozone so could be inaccurate). If you know what pump only will work in there I will throw one in for good measure along with new strainers since I have an access door to the fuel pump its easy. Is there a mass air flow sensor on this thing? It feels like a problem I used to have with my old mustang when the mass sensor was dirty.


BTW I replaced the fuel filter (no change), air filter (dry but looked like it got soaked from a big rain I drove through last feb) and checked my voltage to the pump (Key on, engine off voltage was 12.8v for 1 second...running voltage 13.45v Pump was very quiet and making no odd noises.
Thanks, Mike
mike2626@hotmail.com
__________________

mboemmels is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-21-2014, 07:16 PM   #2
Senior Member
 
Ford Super Duty Owner
Join Date: Mar 2009
Posts: 608
Mike, Look at Rock auto. If you have your pump assembly apart, you can compare it to the pictures. I couldn't find the PFS-48 listed under 94 but it is listed for the 97. I did the same up grade when my pump failed.

1997 FORD F53 Fuel Pump

Richard
__________________

RLS7201 is offline   Reply With Quote
Old 09-21-2014, 07:34 PM   #3
Registered User
 
Join Date: Mar 2013
Posts: 1,919
if I was to take an educated guess at it the pump is fine. The pump pick up sock is plugged from debris in the fuel tank. If you replace the pump, make sure you clean out the fuel tank out of all debris.
jamesrxx951 is offline   Reply With Quote
Old 09-22-2015, 03:22 PM   #4
Junior Member
 
Join Date: Mar 2014
Location: newport beach, ca
Posts: 4
Ok sorry for the massive delay and thanks for the replies this is what I've learned about the f53 regarding fuel pumps that are failing:


If your vehicle idles ok and drives decent around town but falls on its face and starts bucking and popping it's probably the fuel pump. I tried new fuel filter, pressure regulator but was still happening and throwing a lean code, then thought vacuum leak..found a couple but no real improvement...I did all of this because the previous owner had a receipt for the new and improved ps48 fuel pump being installed 11k miles earlier (about 5 years earlier) so I figured that was not it. Sub ford recommended check fuel pressure which I did (39psi at idle and 29 and dropping getting on freeway) I didn't want to hear this because the pump is a pain to change and 500$ but I decided subford knew his stuff. I was in the process of reflooring my rv and realized I could just sawzall a access hatch over the center of the fuel tank and do it all from inside! a few careful measurements to find center and I punched a drill bit carefully through the floor to reveal I was centered (remember to drill slow and shallow you don't want to cut wires, fuel lines, or hit the tank) then I used my battery powered jigsaw to cut out the 6x6" hatch. voila! popped off the fuel lines with a fuel filter line remover and a modified sharpie marker cap and pulled pump out. took the pump apart and noticed fuel socks were in bad shape so went and got a new set with a new turbine style pump motor from ebay (only 1 guy offered the right one, the others were the old style pump...same deal with all auto parts stores...wrong pump, not turbine style, not for the pfs48) and fixed my rv!


runs like a raped ape up the cajon pass (6% grade for at least 5 miles)
I do still have a lean code but now have black exhaust smoke until it warms up...this is due to the next issue which is the broken 460 rear exhaust stud causing an air leak which tells the ecu to richen the mixture when it is actually fine. the issue goes away when the motor heats up and manifold seals out the exhaust leak at normal operating temp...at least that is my theory. anyone else have lean code from exhaust manifold leak? I'm thinking that the crap stock pumps would lean out the motor and cause the exhaust manifold to heat up too much and break the studs. so one faulty design causes the other...
mboemmels is offline   Reply With Quote
Old 09-23-2015, 01:40 AM   #5
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,516
So what pump did you get off ebay?
Was it the Vortech 8F001-265?
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 09-23-2015, 12:57 PM   #6
Junior Member
 
Join Date: Mar 2014
Location: newport beach, ca
Posts: 4
wow that vortech pump is pricey! ill have to go search for the box for part number but it was a private label and ran about 150.00 and included new pigtail and filters
__________________

mboemmels is offline   Reply With Quote
Reply

Tags
f53, fuel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Pump Help whaase Ford Motorhome Chassis Forum 1 09-08-2014 02:29 PM
Winnie fuel pump issue sesdawg Class A Motorhome Discussions 22 08-08-2014 05:21 PM
Fuel Lift Pump Inoperative marwell5 Class A Motorhome Discussions 3 06-23-2014 04:54 PM
Fuel pump replacement after-action report and lessons learned. Elexwiz Ford Motorhome Chassis Forum 4 05-03-2014 06:50 PM
1990 Bounder 34s Ford fuel pump madjack Vintage RV's 3 12-30-2013 03:13 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×