RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Spartan Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-18-2016, 10:04 AM   #1
Junior Member
 
Join Date: Apr 2016
Posts: 1
MH won't start!

Year: 2000
chassis: Spartan
engine:diesel pusher
Model: Newmar Kountry Star
symptoms: engine won't crank
what has been done so far: New house batteries, starter batteries fine as generator cranks and runs fine, checked ignition circuit breakers, checked fuses, re-checked battery connections, turned on house batteries, battery boost didn't help, DH hears solenoids clicking when turn to start.

Just purchased Wednesday and brought it home to clean, sanitize and replace fresh water, and stock with necessary items. Then this happens. We have an HOA so no motorhomes can be here. Had exception to clean and stock and need to get it started. Don't want to have it towed. $$$$
__________________

jfailinger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-18-2016, 10:14 AM   #2
Senior Member
 
USMCRET's Avatar
 
Newmar Owners Club
Join Date: Jul 2011
Posts: 1,883
I'm not familiar with your exact coach, but I have a KSDP on a Spartan as well.

Check the hot wires at the starter for clean connections, and check the starter solenoid as well. The solenoid is a known problem child. Below is a picture of mine.
Attached Thumbnails
Click image for larger version

Name:	Electrical2.jpg
Views:	58
Size:	210.3 KB
ID:	124492  
__________________

__________________
2005 Newmar KSDP 3910
ISC on a Spartan
USMCRET is offline   Reply With Quote
Old 04-18-2016, 10:14 AM   #3
Community Moderator
 
TonyDi's Avatar


 
Newmar Owners Club
Join Date: Feb 2011
Location: Central NJ
Posts: 18,323


Sorry to here about your problems already. Your generator starts on the house batteries not the chassis batteries. So if the chassis batteries are dead the generator would still start. When you push the boost start you should hear a solenoid which connect both banks of batteries. If this solenoid is not working it will not work. Have you tried to jump start? I'd look deeper into the chassis batteries.

Good luck.
__________________
Tony & Ruth........... FMCA#F416727
2016 London Aire 4519, Freightliner chassis, Cummins ISX, 2018 Jeep Wrangler Unlimited, Blue Ox Avail with AF1. TST 507 TPMS
TonyDi is online now   Reply With Quote
Old 04-18-2016, 10:16 AM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 18,515
Welcome to iRV2.
Sorry you're here with problems.

Being A spartan chassis , I'll assume you have a, Cummins engine ?


Do you know the engine size ? ISB , 5.9 ? ISC, 8.1 ?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator Won't Start - Engine Won't Crank Rob Howden RV Systems & Appliances 10 08-02-2015 08:35 PM
2007 600HP ISX stalled after start, now won't start slemnah Cummins Engines 2 01-26-2015 09:06 AM
Only start on Aux Start tulsa Monaco Owner's Forum 18 12-05-2011 03:46 PM
1999 ISC/330 no start, suspect start/run solenoid location question daveshan Cummins Engines 0 11-05-2011 06:36 PM
Jacks won't retract and engine won't start HLB MH-General Discussions & Problems 12 07-31-2009 11:22 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×