RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Spartan Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-13-2016, 09:23 PM   #1
Senior Member
 
Newmar Owners Club
Join Date: May 2012
Location: Fayetteville, NC
Posts: 137
Weird steering problem on my 2005 DutchStar 4010

I was driving home from a trip this past February. After I made a 90 degree right turn my steering wheel stayed at around 45 degrees while I was driving straight. Very odd to say the least. When I could pull over I crawled under to see if anything obvious was loose/broken, or not there. Nothing obvious looked out of place. I continued driving for a few minutes when my wheels decided that they should point in the same direction 'I' had the steering wheel, talk about heart stopping, well, maybe it didn't stop. I suspect that the 7,000 pound truck I tow and the low speed I was driving helped the wheels to turn true to the road so the wheels and steering wheel were both in sync.

Luckily I wasn't too far from a Spartan repair shop off i95. They didn't find anything but noticed the fluids were a bit low. They couldn't reproduce the problem. Whe I continued my drive home a few weeks later I didn't have any further problems.

Has anyone else had this issue? Should I not be overly concerned about this?

Thanks,

Mitch Johnson
__________________

__________________
2005 Newmar Dutchstar 4010, Spartan Chassis
Blue Ox Avanta LX towbar, AF One Brake System
2013 Ford Fusion
Mitchone is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-14-2016, 07:38 AM   #2
Senior Member
 
AFChap's Avatar
 
Winnebago Owners Club
Spartan Chassis
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 4,942
Never heard of this. I would definately be concerned. It did not happen for no reason. Since both wheels were apparently pointed in the same direction at all times but not in sync with the steering wheel, I would be looking at the steering linkage, box, etc.
__________________

__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Old 04-14-2016, 09:13 PM   #3
Senior Member
 
Newmar Owners Club
Join Date: May 2012
Location: Fayetteville, NC
Posts: 137
Thanks. The Spartan techs looked at all that and found nothing.
__________________
2005 Newmar Dutchstar 4010, Spartan Chassis
Blue Ox Avanta LX towbar, AF One Brake System
2013 Ford Fusion
Mitchone is offline   Reply With Quote
Reply

Tags
steering



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slideout problem with 2005 Dutchstar myshaggydog Newmar Owner's Forum 4 11-16-2015 02:05 PM
2004 DS 4010 w/Cummins 370hp oil consumption TinkerBell Newmar Owner's Forum 11 03-09-2015 12:36 AM
Looking for Former Dutch Star 4010 owner taffrail Newmar Owner's Forum 10 12-16-2013 10:25 PM
One jack..slightly down..2010 Dutch star 4010 litespeed Newmar Owner's Forum 9 11-18-2013 01:37 AM
2005 dsdp 4010? Dragnflys Newmar Owner's Forum 11 04-10-2009 02:35 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.