Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-31-2014, 06:53 PM   #1
Member
 
okiegirl2u's Avatar
 
Fleetwood Owners Club
Join Date: Aug 2012
Posts: 42
08 Revolution no taillights

Trying to get out of town for a couple days and try out our new coach. Planning on leaving early am , but light check reveals no taillights, or brake lights . Oh wow, if that is true can't believe we drove it home from dealership yesterday in a driving rain storm. Any chance this is operator error, we feel like we have everything on. He's checking fuses now, fingers crossed on that one. Suggestions appreciated!
__________________

__________________
okiegirl2u is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-31-2014, 07:09 PM   #2
Member
 
okiegirl2u's Avatar
 
Fleetwood Owners Club
Join Date: Aug 2012
Posts: 42
Fuses are good, have rear blinkers, and backup lights and taillights but no brake lights . Shouldn't the brake lights just come on when you push the pedal?
__________________

__________________
okiegirl2u is offline   Reply With Quote
Old 07-31-2014, 07:46 PM   #3
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 4,516
The sockets corrode easy I just about always have something out due to corrosion. You can check at the trailer plug or just take the three screws out and check the socket for power.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 07-31-2014, 07:51 PM   #4
Senior Member
 
waroland's Avatar
 
Join Date: May 2009
Location: Mt Juliet, TN (Homebase)
Posts: 432
On my 2002 there is a bank of relays that repeat the power to the rear lights on the coach. They are located in the battery compartment. You may have the same set-up.
__________________
2002 Fleetwood Revolution 38B
2006 Honda CR-V Air Force One
waroland is offline   Reply With Quote
Old 08-01-2014, 07:20 PM   #5
Member
 
Join Date: Aug 2013
Posts: 41
My 07 fleetwood the brake lights only work with the engine running
__________________
rocky34 is offline   Reply With Quote
Old 08-02-2014, 10:21 PM   #6
Member
 
okiegirl2u's Avatar
 
Fleetwood Owners Club
Join Date: Aug 2012
Posts: 42
Thanks everyone! Turns out the bulbs were bad, looked like moisture may have been getting into the cover somehow. Changed bulbs and finally started our maiden voyage yesterday. Loving it, this coach rides like a dream! Love it. Also KOA in Hot Springs AR is great!
__________________
okiegirl2u is offline   Reply With Quote
Old 08-03-2014, 07:30 AM   #7
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 4,516
Quote:
Originally Posted by okiegirl2u View Post
Thanks everyone! Turns out the bulbs were bad, looked like moisture may have been getting into the cover somehow. Changed bulbs and finally started our maiden voyage yesterday. Loving it, this coach rides like a dream! Love it. Also KOA in Hot Springs AR is great!
Glad to help that's the first place I look everytime.
__________________

__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Reply

Tags
lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ancira RV for a new Revolution MoHoGo Class A Motorhome Discussions 12 07-01-2014 08:30 PM
American Revolution 42G or Ellipse/Tour QD BernerDad Class A Motorhome Discussions 24 06-06-2014 01:36 PM
2008 Revolution LE M40E Mark B Fleetwood Products Owner's Forum 7 01-12-2014 08:17 PM
American Coach: Thinking of moving up to a Revolution poodles Fleetwood Products Owner's Forum 4 06-25-2013 06:02 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.