Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-06-2011, 01:12 PM   #1
Junior Member
 
Join Date: Apr 2011
Posts: 4
Unhappy 12 Volt plug-in fuse problem

Hi,
We blew the fuse to the 12 volt plug-ins, that are mounted on the front dash of our 2003 Scottsdale RV. Can't seem to locate where the fuse is to replace it. Tried all the usual locations but no luck. Thinking that maybe its in a wiring harness(?) running under the front dash to engine compartment? Anybody else run into this problem? If so, maybe you might share your solution? These plugs get used a fair amount so we'll be needing them in the future. Ideas? Thanks!! Mike
__________________

__________________
roadrunner54 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-06-2011, 01:19 PM   #2
Junior Member
 
Join Date: Apr 2011
Posts: 4
Found it on the dash in a panel that looks likes an airbag panel.
__________________

__________________
roadrunner54 is offline   Reply With Quote
Old 06-06-2011, 01:50 PM   #3
Senior Member
 
RJay's Avatar
 
Newmar Owners Club
Join Date: Jan 2010
Posts: 4,589
Thanks for getting back to us and letting us know the solution.
__________________
2007 Newmar DSDP 4023
Discovery is seeing what everyone else has seen and thinking what no one else has thought.
If you want to see what man made go East; if you want to see what God made go West.
RJay is offline   Reply With Quote
Reply

Tags
2003 scottsdale, fuses, 12 volt



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse Blows- "40A IGN A" fuse - HELP!! jntrox Workhorse and Chevrolet Chassis Motorhome Forum 7 08-05-2012 08:19 PM
Generator Spark Plug Problem Greg Lepage Class A Motorhome Discussions 2 11-27-2010 10:44 AM
12 volt electrical problem caesar Alpine Coach Owner's Forum 9 08-24-2010 02:27 PM
120 volt receptacle problem stormincb Winnebago Industries Owner's Forum 20 07-07-2009 02:00 PM
12 volt coach problem thebear National RV Owner's Forum 1 12-23-2008 10:29 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.