Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-21-2014, 09:09 PM   #1
Join Date: Apr 2012
Location: Virginia Beach Va.
Posts: 79
Send a message via Skype™ to Vaflatlander
Red face 120 volt partial power loss

What seemed like an easy problem has become a real head banger. While prepping for our first long trip, I noticed my microwave was off and thought little of it till I tried the front tv nothing rear tv same bathroom and dinette receptacle all out. Receptacle in kitchen and bedroom, inverter all work. CB panel has no tripped breaker and all are hot. Does anyone know of a juction box in the area of the fridge that would tie these problems together. I did open the slider.I also back fed the circuit using the bedroom to BR tv recptacle. This brought all but the MW to life. Any help would be appreciated thank you Ed
2000 National tradewinds.

Ed & Sharon Ward ,Virginia Beach, Va.
2000 National RV, 37' Tradewinds
3126 Cat 300hp Allison 6spd Fl xc chassis
Vaflatlander is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-21-2014, 10:10 PM   #2
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,950
The two most common issues with partial power loss are tripped GFIC s and loose connections in the 110 circuit panel .
My coach has 2 GFIs and most all other outlets are daisy chained through them. So look at all your outlets , trip and reset any GFIs you find.
My microwave has a dedicated circuit breaker in the main panel.
First , I'd pull the microwave cord from it's outlet and test for power. Then if no power to the outlet, disconnect the coach from shore power , pull the face off the 110 panel and check all the screws that hold the wiring to the circuit breakers. Take your multi meter and test for zero ohms through the breaker, if they test ok then place the face back on and power up the coach. If still no power to microwave, particularly if you have a circuit breaker marked for the microwave , turn it off and see if any other outlet goes dead, if you have a dead outlet between the micro and the circuit panel then that outlet box will be the wiring junction, and then, you will need to pull the outlet and check connections.
EDIT on re-reading , I see that you said all breakers are hot , sorry I missed that.

99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-22-2014, 01:53 AM   #3
Community Moderator
RV Wizard's Avatar

Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 11,807
Check circuit breaker on inverter.
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No coach power from generator qdup Class A Motorhome Discussions 12 05-22-2014 12:38 PM
No power to coach unless RV is running dvleemin Class A Motorhome Discussions 9 03-27-2014 07:33 PM
08 Select Partial 12v Power loss cbu38 Travel Supreme Owner's Forum 5 03-22-2014 06:56 AM
No DC power to motorhome glow4004 Monaco Owner's Forum 12 12-02-2013 09:22 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:17 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.