Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-14-2016, 10:14 AM   #1
Junior Member
 
Join Date: May 2015
Posts: 3
12volt issues

We lost 12 volt power in our Holiday Rambler Scepter. New fully charge new batteries. Help.
__________________

__________________
Littledaisy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-14-2016, 10:25 AM   #2
Senior Member
 
Join Date: Nov 2015
Posts: 4,080
Did you 'hook up battery cables backwards'???

Verify NEG cable goes to frame (GRD)

IF backwards you have blown the reverse polarity fuses on converter.

Should still have 12V DC if connectd to an AC Power Source (Cord or Generator)

No converter......
Still need to check battery cables hooked up correctly
Then check inverter for tripped breakers

Also need to check Fuse panel for blown fuses
Might have to manually extend slide of blocking
__________________

__________________
Old-Biscuit is offline   Reply With Quote
Old 04-14-2016, 11:05 AM   #3
Senior Member
 
m.elliott63's Avatar
 
National RV Owners Club
Join Date: Nov 2015
Location: Monrovia, IN
Posts: 199
Check to be sure that someone didn't hit the disconnect switch. Mine is in the entry area ans someone going in or out could accidently brush against it. Happens sometimes with my step switch in the same area.
__________________
1998 National Seabreeze 1330 Limited Chevrolet P37 chassis 7.4 Vortec 2014 Jeep JKU Sport Toad
Me, Beautiful DW, sometimes kids & grandkids
m.elliott63 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
12volt, transmission and engine issues. bobioknight Country Coach Owners Forum 10 04-05-2013 10:19 PM
1990 bounder chevy 454 Can't get 12volt lights on joe1 MH-General Discussions & Problems 5 03-18-2008 09:08 PM
Installed A 12volt Outlet at the ramp door 56Nomad Toy Haulers Discussion 22 11-30-2005 09:03 PM
grease on 12volt connections RKL2 Winnebago Industries Owner's Forum 3 07-28-2005 02:30 PM
'96 Aventurer 30' = No 12volt power Ol'Joe Winnebago Industries Owner's Forum 4 07-12-2005 04:55 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.