Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-27-2015, 03:40 PM   #1
Junior Member
Join Date: Sep 2010
Posts: 11
1997 bounder engine batter dead

the battery on my 97 bounder is low and will not start the engine without a jump, i notice that i hear a clicking noise in the engine compartment in the front right hand corner coming from the solenoid located behind a circuit board. I replaced the solenoid about a year ago . I cant figure out why this clicking noise, the key is off and the battery is to low to start the engine, however when i jump the engine and it starts that clicking noise goes away , any sugestions ?

thanks , dave

sdc is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-27-2015, 04:56 PM   #2
Senior Member
Leary54's Avatar
Freightliner Owners Club
Join Date: Dec 2011
Posts: 164
Take your battery out and get it tested.

Leary54 is offline   Reply With Quote
Old 05-27-2015, 05:32 PM   #3
Senior Member
mhbell's Avatar
Thor Owners Club
Ford Super Duty Owner
Georgie Boy Owners Club
Join Date: Feb 2011
Location: Ogden Utah
Posts: 436
Not only get your battery tested but clean the battery cables. A quick test is to turn on the head lights and have someone hit the starter. If the lights go out then it may be the battery cables need to be cleaned. Also be sure you check the specific gravity of each cell when you test the battery. A load test will not tell if you have a bad cell. make sure battery is fully charged. Chances are if it starts with a jump then your battery could be bad.
2006 Four Winds Hurricane 31D, Steer Safe, CHF, 50 Amp Conversion, 3000 Watt Inverter, Toad is a 2007 Jeep Liberty Sport. Blue Ox Aladdin Tow Bar, Apollo Braking System
mhbell is offline   Reply With Quote
Old 05-27-2015, 05:46 PM   #4
Senior Member
BFlinn181's Avatar

Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 12,641
The clicking of the relay could be because voltage is low enough that the electromagnet in the relay doesn't have the strength to overcome the spring holding the contacts apart. I wouldn't worry about it until you've done the suggested actions above and made sure your battery and connections are good.

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote

bounder, engine

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stop engine light came on Pogo Cummins Engines 11 02-01-2015 10:36 AM
Axis-Vegas engine noise muffled mcr1010 Thor Industries Owner's Forum 1 11-06-2014 07:26 PM
Engine Mount Question JSutton1 Vintage RV's 6 08-17-2014 04:50 AM
The Doggone Yellow Check Engine Light (C.E.L.) troth Winnebago Industries Owner's Forum 1 05-06-2014 09:05 AM
Engine "miss" at 25-30 mph linda7915 Workhorse and Chevrolet Chassis Motorhome Forum 17 12-20-2013 08:57 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:34 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.