Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-03-2016, 04:21 PM   #1
Junior Member
Join Date: Dec 2014
Posts: 2
1997 Onan 5000 Emerald Plus not running

Having a problem with an Onan 5000 gen. It will start and run as long as you hold the starter button in. As soon as you let off the button it stops. This happens from any of the start buttons. This gen. had been running great and after sitting for 30 days it started doing this. Today it started and ran about 4 minutes the shut down and went back to starting and stopping as soon as you let off the start button, however again if you hold the button in it will run as long as you hold it in. Any help with this would be great.

fitz16316 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-03-2016, 04:41 PM   #2
Senior Member
Tha_Rooster's Avatar
Join Date: Aug 2008
Location: Georgia
Posts: 4,072
Sounds like it's starving for fuel how much fuel do you have?

2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 04-03-2016, 05:28 PM   #3
Senior Member
Join Date: Jul 2014
Posts: 5,466
Check the oil level. It could be shutting down due to low oil or oil pressure. Holding the button overides the shutdown system.
twinboat is online now   Reply With Quote
Old 04-03-2016, 06:46 PM   #4
bob_5297's Avatar
Join Date: Jan 2013
Posts: 85
Check your battery's too. Sometimes thier not enough power to run.
bob_5297 is offline   Reply With Quote
Old 04-03-2016, 06:58 PM   #5
Senior Member
Dave-Oh's Avatar
Join Date: May 2015
Location: Silver Spring, MD
Posts: 285
I had the same issue, ran until you let go of the start button.

once you let go of the button and it shuts down, it will blink, push again and you'll get a secondary code: a number of blinks, a pause and a second set.

Mine had the following: 3 blinks, then 4 blinks <pause> 5 blinks. I emailed cummins and they told me what the code 3, 45 meant.

Mine basically had to have a bit of work done, including a new wiring harness.

good luck. Get the codes, it may give you a good starting point (after you've checked the oil level and make sure your gas tank is greater than 1/4 full)
2016 Tiffin Allegro 32 SA
2015 Chevy Malibu LTZ Toad
Dave-Oh is offline   Reply With Quote
Old 04-04-2016, 06:47 AM   #6
Junior Member
Join Date: Dec 2014
Posts: 2
Thanks, the gas tank is full and the oil is full. Onan said it could be the brushes are glazed over and it is not sensing any out put and will shut down.

fitz16316 is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 6.5 Onan Emerald Plus Fuel Filter Afubar RV Systems & Appliances 13 01-13-2016 08:40 PM
Onan Emerald Plus 5000 Question buzzyb Winnebago Industries Owner's Forum 6 10-01-2013 06:50 AM
Onan Emerald plus 5000 genset-Headach trailblaze Workhorse and Chevrolet Chassis Motorhome Forum 3 09-02-2013 06:17 PM
Onan Emerald Plus 5000 won't keep running Romer1 Winnebago Industries Owner's Forum 24 08-22-2007 04:42 PM
Onan Emerald Plus won't start RonTon Winnebago Industries Owner's Forum 7 12-13-2005 10:08 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:26 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.