Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-25-2014, 03:49 PM   #1
Senior Member
abrasv's Avatar
Monaco Owners Club
Join Date: Jul 2009
Location: Mo
Posts: 204
2 of 3 Electric Sunvisors quit working

On our '05 Discovery we have 3 CAREFREE of COLORADO electric sunvisors for the windshield. Other day I had all 3 down in a campground and all were working great. Went to raise them back up and only the passenger side would respond. Center one and middle one would not go up or down. Checked the fuse (and even replaced it) but knew that if one still worked then the fuse was ok. Tested with a trouble light the incoming wires and they were hot. Thought it might be the switches so swapped the good one with the others (one at a time) and no help. Wiring has to be ok with all the checks I've done. Right?

Since the shades were only about half way down I pulled on them thinking the gears may be bad or caught or bound up. They both pulled down with no problems and you could actually hear the gears inside turning. Next step is to take them down completely and hook them up on the workbench to see what happens. Before doing that I wanted to see if anyone had any other ideas.

Jim and Carol
2005 Monaco Windsor
2010 RAM 1500 Quad Cab 4x4
abrasv is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aquahot vs electric heat economy 8wheels Class A Motorhome Discussions 15 10-22-2014 11:14 AM
Air Conditioners quit working MaddMarston Gulf Stream Owner's Forum 12 05-18-2014 06:13 PM
Electric step not working 2007 QRH espy1949 Tiffin Motorhomes Owners Forum 8 03-28-2014 10:48 AM
Electric couch/bed problem dnystrom Winnebago Industries Owner's Forum 4 03-16-2014 07:03 PM
2010 keystone bullet slideout quit working 5string71 Travel Trailer Discussion 1 02-23-2014 07:50 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:31 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.