Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 03-16-2016, 03:36 PM   #1
Junior Member
Join Date: Nov 2014
Posts: 7
2000 Fleetwood Flair Engine Cranks, but won't start

RV sat for about 3 months, then when I tried to start it a month ago, it took a very long time to start - way longer than one would expect for an FI engine (454 Chevy on WH chassis), but it did finally start. Fired up the generator also.
Today, I tried to start it, but it just cranked and cranked. I tried the generator, which started, but then died in about 3 minutes and wouldn't restart. Gas gauge says ~3/8 tank, but just to be sure, I am going to first do the simple thing and go get 6 gallons of gas to throw into it. Anyone got any other ideas or had similar problems?

AZNMTX_RVer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-16-2016, 04:54 PM   #2
Senior Member
Join Date: Dec 2014
Posts: 127
Check to see if you have fuel and spark. Then find the reason why you are missing one or the other.

When you turn the ignition on, you should be able to hear the whine of the fuel pump in the gas tank. Have your wife turn the key on (but not to start) while you lay under the MH near the tank.

You can also confirm that you have fuel pressure in the fuel rail by momentarily pressing the fuel schrader valve. You will get a squirt of fuel if you have fuel pressure.

To confirm spark, pull a spark plug wire from a plug. Put the spark plug wire an old spark plug and lay the plug across the engine where it will have a good ground. When you try to start the engine, you should see a strong spark between the electrodes.

I hope that points you in the right direction.

JoeSR is offline   Reply With Quote
Old 03-19-2016, 11:23 AM   #3
Junior Member
Join Date: Nov 2014
Posts: 7
Seems to be the crankshaft position sensor. I have looked on line, but can't find an exact match, that is, a listing for the 2000 P32 Workhorse. The sensor for the same year K3500 has the same mounting scheme, but it has a plastic outer casing whereas the one I yanked out looks to be brass. The diameter of the part appears to be the same as mine, though. Anyone bought an aftermarket sensor and/or have any advice here?
AZNMTX_RVer is offline   Reply With Quote

engine, fleetwood

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine cranks stops after 4 cranks, no start long53 Workhorse and Chevrolet Chassis Motorhome Forum 26 07-21-2015 09:18 PM
Engine cranks but won't start bluegrassrv Country Coach Owners Forum 8 08-14-2014 03:27 PM
Cat cranks but won't start VanDiemen23 Caterpillar Engine Forum 10 10-31-2013 12:40 AM
F460 engine cranks,won't start and clicks behind power distribution box Rvch56 MH-General Discussions & Problems 2 05-05-2013 09:59 PM
Onan 5000 Cranks but no start Wanabee FTer MH-General Discussions & Problems 2 07-27-2010 10:06 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.