RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-22-2019, 08:21 AM   #1
Senior Member
 
Join Date: Feb 2017
Location: Texas
Posts: 271
2000 Southwind house batteries not charging from alternator possible cause.

There is a solenoid relay in this box that's energised when the engine is running that connects the house batteries to the chassis charging system, it's the came device that's supposed to click when you hit the Aux Start switch on the dash. it's mounted between the 2 buss bars in the back of this box, when energised, it connects the buss bars together, connecting both battery systems.
Attached Thumbnails
Click image for larger version

Name:	20190722_084302[1].jpg
Views:	7
Size:	246.8 KB
ID:	254197  
__________________

__________________
2000 Southwind 32v and a 03 Tracker 5 speed 2WD toad, Roadmaster off road tow bar & 2" drop hitch
Jyrocharlie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-22-2019, 09:10 AM   #2
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 21,146
You've accurately described how the solenoid is supposed to work? Are you saying it does not? Using the Aux Start or when engine is running? Have you verified the solenoid itself functions (jumper 12v to it and see if it engages)?
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition and several other RVs
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 07-22-2019, 09:16 AM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 19,129
Yes it supposed to. Even if it sounds like its working, the internal contacts may not be passing current. The contacts get burned up and don't connect.
twinboat is offline   Reply With Quote
Old 07-22-2019, 10:45 AM   #4
Senior Member
 
Join Date: Feb 2017
Location: Texas
Posts: 271
Gary, sorry for any confusion, mine works fine.

Quote:
Originally Posted by Gary RVRoamer View Post
You've accurately described how the solenoid is supposed to work? Are you saying it does not? Using the Aux Start or when engine is running? Have you verified the solenoid itself functions (jumper 12v to it and see if it engages)?
This was posted for informational purposes only. I see many posts on numerous sites that die after 5 pages with no solutions, not only here but on the WWW mainly. I wanted to make it when a person googles a problem, a solution comes up. My solenoid wasn't working at one time and I had trouble finding out how it was supposed to charge the house batteries.
__________________
2000 Southwind 32v and a 03 Tracker 5 speed 2WD toad, Roadmaster off road tow bar & 2" drop hitch
Jyrocharlie is offline   Reply With Quote
Old 07-22-2019, 10:55 AM   #5
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 18,493
Quote:
Originally Posted by Jyrocharlie View Post
This was posted for informational purposes only. I see many posts on numerous sites that die after 5 pages with no solutions, not only here but on the WWW mainly. I wanted to make it when a person googles a problem, a solution comes up. My solenoid wasn't working at one time and I had trouble finding out how it was supposed to charge the house batteries.

For info then maybe adding this pdf will assist too.
Attached Files
File Type: pdf BCC Mini Gas.pdf (634.4 KB, 7 views)
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-22-2019, 03:08 PM   #6
Senior Member - DIYer
 
Waiter21's Avatar


 
Ford Super Duty Owner
Join Date: Nov 2014
Location: NW Ohio
Posts: 6,258
Yes, That solenoid is supposed to connect the house and chassis batteries together. As mentioned, one of the failure modes is, the solenoid energizes, but the internal contacts don't make. This is the problem I had with mine, so I had to replace the solenoid. You can read about it on my blog site:

Replace battery isolator solenoid in the BCC – 1999 Southwind 35S

ALSO > That solenoid also energizes to charge the chassis battery when you re plugged into shore power.
__________________
1999 Fleetwood Southwind 35S (Ford F53 6.8L V10 275hp 4R100 4 spd trans) - Toad 2003 Saturn Vue.
(www.1999Southwind.com)

It won't do MACH 2, but I can get a sandwich and take a pee.
Waiter21 is offline   Reply With Quote
Old 07-22-2019, 06:03 PM   #7
Senior Member
 
Join Date: Feb 2017
Location: Texas
Posts: 271
Thank you. Mine and yours are near identical.
__________________

__________________
2000 Southwind 32v and a 03 Tracker 5 speed 2WD toad, Roadmaster off road tow bar & 2" drop hitch
Jyrocharlie is offline   Reply With Quote
Reply

Tags
alternator, batteries, charging, house batteries, southwind, wind



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Revolution not charging house batteries from Alternator akeyzoo Fleetwood Owner's Forum 28 06-24-2014 08:00 AM
House batteries not charging from alternator Mr.Wizard Forest River Owners Forum 13 05-09-2014 02:48 PM
House Batteries not charging off alternator patsikes Damon 8 02-04-2014 09:47 AM
Alternator not charging house batteries FDchief Winnebago Industries Owner's Forum 6 06-27-2009 01:23 PM
Cummins alternator not charging house batteries John_Canfield Winnebago Industries Owner's Forum 11 10-17-2006 04:50 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×