Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-21-2015, 07:01 PM   #1
Member
 
Fleetwood Owners Club
Join Date: Nov 2015
Location: Largo, FL
Posts: 41
Blog Entries: 1
2007 Fleetwood Expedition battery problem

Help please
Just took delivery of 2007 Fleetwood Expedition 38L DP last Thursday. A return to the RV world after a 40 year hiatus. Welcome back?
All was fine for first few days. I parked for "long term " (1 week) storage, now,main batteries do not want to come back on line. I get a dim red light on the main battery disconnect switch then it goes out.
I do have >12 volts at both battery banks.
I am able to start both the generator and the engine.
I was looking for the battery disconnect relays and think they are in the battery controller since I can't find them elsewhere.
I suspect problem is with the intelletec battery controller but unable to prove it yet
Just downloaded the service manual and will study it tonight
Any suggestions are welcome and appreciated
Thanks
__________________

__________________
Tom, Connie, & Katie (Wirehaired Dachshund)
2007 Fleetwood Expedition, 300 Cat, Allison 6spd 3000
Fiat 500 Pop toad,Blue Ox Avail, RVi 2 brake
TRV1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-22-2015, 09:12 AM   #2
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
The disconnect relay does require 12c to activate, so a dead battery will prevent it from working. But you say you have +12v or more at the batteries? Maybe just a poor connection, either at the relay or at the disconnect switch.
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 12-22-2015, 01:55 PM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 170
As Gary mentioned, it sounds like a bad connection either at the switch or the relay. That would explain the dim light at first (high resistance at the connection) followed by it going out as the connection heats up. I believe the relays are behind the main pc board in the battery control center box so maybe check the connections on the switch first (and any close by downstream junctions in the wiring harness).
__________________
navigator336 is offline   Reply With Quote
Old 12-30-2015, 04:49 PM   #4
Member
 
Fleetwood Owners Club
Join Date: Nov 2015
Location: Largo, FL
Posts: 41
Blog Entries: 1
Update

Well from bad to worse. Symptoms progressed from loss of main battery power to loss of aux power too. Still good voltage at the battery banks, just not getting past the battery control center. Then generator would not start. Decided to take it in for repair before things deteriorated further. Since the steps could not be retracted, had to knock the pin out from the linkage and bungee them in place.
Found the controller box to be defective and no longer available as a drop in replacement but the individual parts, pcb and seolenoids are. Fleetwood was very helpful in supplying the part numbers and parts are in stock.
Now the waiting game while the wheels of progress slowly grind along.
__________________
Tom, Connie, & Katie (Wirehaired Dachshund)
2007 Fleetwood Expedition, 300 Cat, Allison 6spd 3000
Fiat 500 Pop toad,Blue Ox Avail, RVi 2 brake
TRV1 is offline   Reply With Quote
Old 12-30-2015, 05:13 PM   #5
Senior Member
 
pcurt23's Avatar
 
Join Date: Apr 2010
Posts: 1,295
What was available as a replacement? Since I have the same system I am curious.
__________________
Pcurt
2007 Fleetwood Bounder 38V
pcurt23 is offline   Reply With Quote
Old 12-30-2015, 08:23 PM   #6
Member
 
Fleetwood Owners Club
Join Date: Nov 2015
Location: Largo, FL
Posts: 41
Blog Entries: 1
The original battery controller is an Intelletec 00-00886-100.
Component replacement parts (Fleetwood part #s)
611492 pcb. $379.80
063699 solenoid (relay) $72.00 ea.
__________________
Tom, Connie, & Katie (Wirehaired Dachshund)
2007 Fleetwood Expedition, 300 Cat, Allison 6spd 3000
Fiat 500 Pop toad,Blue Ox Avail, RVi 2 brake
TRV1 is offline   Reply With Quote
Old 01-06-2016, 05:15 PM   #7
Member
 
Fleetwood Owners Club
Join Date: Nov 2015
Location: Largo, FL
Posts: 41
Blog Entries: 1
Update 2

The Warranty folks were contacted by the repair facility. An inspector was sent to have a look, repair was approved, then parts ordered. Hopefully in another 3-5 days we will be actively repairing. Hoping for the best.
Glad we are at home base rather than on the road. 15 days so far, but to be fair, it has been over the holidays.
__________________
Tom, Connie, & Katie (Wirehaired Dachshund)
2007 Fleetwood Expedition, 300 Cat, Allison 6spd 3000
Fiat 500 Pop toad,Blue Ox Avail, RVi 2 brake
TRV1 is offline   Reply With Quote
Old 01-15-2016, 12:17 AM   #8
Member
 
Fleetwood Owners Club
Join Date: Nov 2015
Location: Largo, FL
Posts: 41
Blog Entries: 1
Update 3

Repairs complete and on the road again at the Tampa RV Supershow. PCB and relays were the problem.
Thanks to Harbersons RV for repair work and to Wholesale Warranties for coverage during the first week of contract going into effect.
Overall, a very positive experience.
__________________

__________________
Tom, Connie, & Katie (Wirehaired Dachshund)
2007 Fleetwood Expedition, 300 Cat, Allison 6spd 3000
Fiat 500 Pop toad,Blue Ox Avail, RVi 2 brake
TRV1 is offline   Reply With Quote
Reply

Tags
battery, fleetwood



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Technical house battery charging problem. FIRE UP Winnebago Industries Owner's Forum 26 01-03-2015 09:47 AM
2007 Fleetwood Southwind Aux. Battery Location blade819 Fleetwood Products Owner's Forum 2 11-16-2014 11:12 AM
Battery problem hydro45640 National RV Owner's Forum 8 04-22-2014 12:01 PM
Battery Problem with 2008 Winnebago Vista joycemiddle Class A Motorhome Discussions 2 09-12-2013 07:59 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.