Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-26-2014, 08:24 PM   #1
Junior Member
Join Date: Oct 2014
Posts: 1
2011 Diesel Wont Start

Can anyone help with trying to figure out why RV wont turn start The general works but can't get RV to start. It won't turn over at all. Dash is completely dead. It is a 2011 Coachman with a Freightliner chassis.

Thank you

busymom0413 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-26-2014, 08:37 PM   #2
Senior Member
Freightliner Owners Club
Join Date: Mar 2002
Location: Western WA
Posts: 965
Start by checking all your battery electrical connections, especially the grounds and fuses. If any battery cables run over the frame rail, check for bare wires due to rubbing. Proceed from there with a probe or multimeter checking for power at crucial points. An electrical diagram of your coach/electrical starting system would be invaluable rather than hit or miss trouble shooting.

'07 Winnebago Journey 34H, ISB-02, MH2500
Toad - '08 Ford Taurus X
Blue Ox, Aventa
FleetMan is offline   Reply With Quote
Old 10-26-2014, 10:55 PM   #3
Join Date: Oct 2012
Posts: 55
I agree with Fleetman. Check your battery connections. Photograph the wiring, then remove the cables starting with the negative ground and clean all the cable ends and battery posts. Had the same problem with our coach and I had cleaned the cables just three months before. I had no starter or glow plug indicator and the transmission display didn't light up. (Also your diesel engine will not start unless you are in park or neutral).
Once the cables were cleaned, all was good. Good luck, eh.
2007 Damon Tuscany 4072
Brian & Wendy
Lloydminster Alberta
ARollingHome is offline   Reply With Quote
Old 10-27-2014, 06:08 AM   #4
Senior Member
Country Coach Owners Club
Retired Fire Service RVer's
Join Date: Feb 2013
Location: Ocala, Florida
Posts: 6,295
The only time my coach would not start, cleaning, and eventually replacing the chassis battery terminal connectors solved my problem as well. Take a look to ensure the main breaker is on from the batteries, then disconnect and clean the terminals. Just make sure you get the wires back on exactly as they came off!
FMCA #F431170, GS #822128658, Escapees SKP #112655
2012 Airstream Mercedes Interstate Class B
Medico is offline   Reply With Quote
Old 10-27-2014, 08:06 AM   #5
Senior Member
Mahakal's Avatar
Join Date: Aug 2012
Posts: 153
I had the same issue. My problem was the wire was very loose at the starter.

Sent from my iPad using iRV2 - RV Forum
2015 Ace 30.2
2009 Porsche Cayman
1981 Hondamatic
Mahakal is offline   Reply With Quote
Old 10-27-2014, 09:52 AM   #6
Senior Member
Country Coach Owners Club
Join Date: Jan 2006
Location: Sacramento Area
Posts: 3,228
Your generator may not be started by the chassis battery. Instead it may be started by the house battery.

Your generator and shore power may not charge the chassis battery.

You should have a Boost switch that will connect your house battery to your chassis battery to help start the chassis engine. Hold that switch on while trying to start the engine.

It sounds like your chassis battery is dead.
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is online now   Reply With Quote
Old 10-27-2014, 09:57 AM   #7
Senior Member
D Lindy's Avatar
Winnebago Owners Club
Join Date: Aug 2013
Posts: 1,258
Sometimes it's the simplest things, is the chassis battery switch (salesman switch) turned on, sometime or another it could have been accidently turned off from the sounds of it.
2012 Journey 40U (Our Incredible Journey)
2008 Dodge Dakota
2004 Subaru Baja
D Lindy is offline   Reply With Quote
Old 10-27-2014, 10:22 AM   #8
Senior Member
Tha_Rooster's Avatar
Join Date: Aug 2008
Location: Georgia
Posts: 4,074
Does it have a chassis battery disconnect?
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 10-27-2014, 10:25 AM   #9
Senior Member
Tha_Rooster's Avatar
Join Date: Aug 2008
Location: Georgia
Posts: 4,074
Sorry D Lindy for above post got busted for not reading all post.
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 10-27-2014, 05:42 PM   #10
Join Date: Mar 2011
Posts: 35
also check the salesman switch

racer478r is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Cummins won't start glennk Cummins Engines 2 08-25-2014 08:16 PM
Neither engine nor generator will start. benj Workhorse and Chevrolet Chassis Motorhome Forum 9 05-26-2014 03:34 AM
Magnum Auto Gen Start problem? Miramar2014 Thor Industries Owner's Forum 2 04-13-2014 08:11 AM
Quiet Portable Inverter Generator with Remote Start iMaki Travel Trailer Discussion 6 01-31-2014 08:02 AM
Ford F53 V10 will not start - Any ideas ? Markrving Ford Motorhome Chassis Forum 10 12-31-2013 04:25 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:39 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.