Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-19-2016, 03:14 PM   #1
Junior Member
 
Join Date: Jun 2016
Posts: 2
2014 Windsport 34F Electrical issue

First off, we have had constant issues with the electrical system. Just replaced the radio head unit not too long ago and both cabin batteries. Engine battery test good. When I start the RV, I can start the generator and outside lights work fine with engine running. When shutting engine off, the lights start to dim and the lights and generator shut off. Runs fine with engine running. Made sure switch wasn't in store mode and starts back up fine so I know it's not a battery issue. Any advice?

Thanks
__________________

__________________
dkhillman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-19-2016, 07:36 PM   #2
Senior Member
 
ChasA's Avatar
 
Join Date: Mar 2007
Location: Apex, NC
Posts: 1,857
Hi Dk,
Welcome. It sounds like you have dead or miswired house batteries. Check voltage of the batteries without anything running and not plugged in to shore power. You should have at least 12.4 volts. You say your batteries were replaced "not too long ago" . Please define that. 1 week, 1 month. How long? How have the batteries been maintained? Has the coach been plugged in to shore power? Answer these questions and the folks here will surely help you out.
__________________

__________________
2010 Winnebago Journey Express 34Y
2010 Freightliner XCS (mfd 9/'09)
'07 Saturn Vue V6
ChasA is offline   Reply With Quote
Old 06-19-2016, 10:18 PM   #3
Junior Member
 
Join Date: Jun 2016
Posts: 2
Batteries are only a few weeks old. They are AGM maintenance free batteries. The RV is kept plugged in to 50 amp while at my house. I labeled all the wires when batteries were removed and put them back like they were. Haven't checked with volt meter, but gauge inside says they are full. Hope that helps
__________________
dkhillman is offline   Reply With Quote
Old 06-19-2016, 10:21 PM   #4
Senior Member
 
Join Date: Jun 2016
Location: Nine Mile Falls WA / Arizona City AZ
Posts: 524
I agree with ChasA.... but would like to stress that the ground from the lights and the gen set is great... but would bet that the ground between the coach batteries and lights have an issue....

Do you have a switch that links the coach batteries to the start batteries... does turning on this switch on... correct the problem... if the problem still exists I'm moving more towards a ground issue.. as this switch links the (+) side of the batteries... expecting the ground to be in place and good...
__________________
jelag is offline   Reply With Quote
Reply

Tags
electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just picked up 2014 Hurricane 34F today!! texgirl Thor Industries Owner's Forum 5 12-23-2015 10:52 AM
2015 Windsport 34F captjsr Thor Industries Owner's Forum 6 12-13-2015 07:07 AM
Windsport 34f BankerCajun Thor Industries Owner's Forum 1 05-08-2015 04:12 PM
2014 Windsport 27K- dc electrical help LLFranks Thor Industries Owner's Forum 4 05-03-2015 07:54 PM
2014 vs 2015 Thor Hurricane 34F bcreekmore Thor Industries Owner's Forum 12 06-18-2014 04:21 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.