Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-02-2015, 06:43 AM   #15
Senior Member
 
Bo Walker's Avatar
 
Winnebago Owners Club
Join Date: Sep 2011
Posts: 240
Thanks for the replies. I flushed the radiator. But I haven't cleaned the fins.
I will replace the 180 thermostat with the 195. After doing that and cleaning the exterior, I hope it solves the problem.
I am afraid it will over heat and blow a head gasket or something.
I'm not sure that overheating isn't why an exhaust manifold gasket blew two years ago.
It has never skipped a beat while running so hot. I'm just afraid it will damage something.
Thank you all for getting back on the right track.
__________________

__________________
Me & my Hun RVing for fun!
Bo Walker is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-03-2015, 12:22 PM   #16
Senior Member
 
Bo Walker's Avatar
 
Winnebago Owners Club
Join Date: Sep 2011
Posts: 240
Oh boy! now what have I done? I installed the new 195 degree thermostat. I wonder what and how I upset something. She cranks and runs rough for a little while, then smooths out and idles high. This is not right. It has never done like this before.
Please tell me what to check.
__________________

__________________
Me & my Hun RVing for fun!
Bo Walker is offline   Reply With Quote
Old 10-03-2015, 03:40 PM   #17
Senior Member
 
Join Date: Mar 2015
Location: Newcastle, WA
Posts: 287
Perhaps you knocked off a vacuum hose when replacing the thermostat. This would cause a high idle.
__________________
Kevin n Chriss
2015 Newmar 3103 Bay Star -The Pay Car-
1993 Fleetwood 28T Bounder -The Flounder-
Steady_Rest is offline   Reply With Quote
Old 10-03-2015, 03:47 PM   #18
Senior Member
 
Bo Walker's Avatar
 
Winnebago Owners Club
Join Date: Sep 2011
Posts: 240
I wish it was that simple.
I did a test drive and discovered not only does it run rough when first cranked and idles fast, but doesn't shift into high gear. It is running in limp mode. All I know to do at this time is take it to a transmission shop Monday. I hope all this sums up to be only one thing, like a sensor or solenoid.
__________________

__________________
Me & my Hun RVing for fun!
Bo Walker is offline   Reply With Quote
Reply

Tags
454, cooling, heat, heating



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Timing a 1990 454 TBI - Itasca Windcruiser 37 Bluelagoon Workhorse and Chevrolet Chassis Motorhome Forum 7 05-22-2015 01:55 PM
Chev 454 P30 Chassis Engine surging - Audio clip linked! klasicecream Workhorse and Chevrolet Chassis Motorhome Forum 29 03-30-2015 07:05 PM
454 Swap Longblock cptmiker Workhorse and Chevrolet Chassis Motorhome Forum 6 07-26-2014 11:00 AM
95 454 Head Casting Numbers jcgribks Workhorse and Chevrolet Chassis Motorhome Forum 0 05-04-2014 05:51 PM
1988 Tioga 27' E350, 454 sluggish up hills mfsb Vintage RV's 11 10-20-2013 03:58 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.