RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-08-2019, 01:29 PM   #1
Junior Member
 
Join Date: Dec 2010
Posts: 9
A/C sometimes kills generator on startup

Have front and rear Duo-therm 630035-321 a/c's with heat pumps. Sometimes front a/c starts right away, with no delay which it should have, and kills the gen set. This is in an 05 Diplomat, owned since new. A/C's normally have about 2 minute delay before starting. The front a/c starting right away is has just started happening but it doesnít do it every time. When it does it kill 8000 watt gen set! Can starting capacitor malfunction occasionally or is the problem in a relay somewhere? If so' where is it located? Thanks in advance.
__________________

Mistaya is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-08-2019, 03:07 PM   #2
Senior Member
 
Join Date: Aug 2017
Posts: 1,092
Does it kill the generator just after the generator is started or after the generator has been running for some time. Do you have a gas or diesel generator ?
__________________

__________________
1993 Tiffin Allegro Bay 32'
Soppy is online now   Reply With Quote
Old 01-08-2019, 03:38 PM   #3
Junior Member
 
Join Date: Dec 2010
Posts: 9
Diesel and it was running and up to operating temp..
Mistaya is offline   Reply With Quote
Old 01-08-2019, 04:01 PM   #4
Ex Millwright / Army Vet
 
marjoa's Avatar


 
Join Date: Aug 2016
Location: FTers. We're all over the place.
Posts: 2,439
Quote:
Originally Posted by Mistaya View Post
Can starting capacitor malfunction occasionally......
Not 100% sure a bad or weak capacitor would cause this malfunction, but I believe that's where I'd start for sure. You should have 3 capacitors, and they should be up top, under the AC plastic shroud, mounted behind a metal panel on the side of the AC unit.

Fan Capacitor
Start Capacitor
Run Capacitor

Assuming your capacitors are OEM, they're 13yrs. old and pretty cheap to replace. I would just replace all 3. You could do all 3 yourself for about $50. I carry new spares.

If you go up on the roof to check, remove the shroud and have someone start the AC while you're standing right there. Some further evidence may reveal itself.

One other thought...are you sure both breakers are ON and OK next to your generator start switch? In other words are you sure your genny is producing 50amps and not 30amps? Maybe flip both breakers OFF and then back ON to be sure.
Attached Thumbnails
Click image for larger version

Name:	coil-1.jpg
Views:	32
Size:	318.5 KB
ID:	231346   Click image for larger version

Name:	coil-2.jpg
Views:	36
Size:	288.6 KB
ID:	231347  

__________________
TEAM Martin & Joanie, FTers, RVM#181, "we speak fluent sarcasm"
2012 WGO Vista 35F, 5 ST, Toyo M122's/duallys, Centramatics (all around), TPMS, ScanGuage II, Safe T Plus, SS Rear Trac Bar, CHF (F/R), Koni FSD's, 2017 FORD Fiesta Toad, Escapees
Making Traveling, FTing and Our Motorhome "GREAT AGAIN".
marjoa is online now   Reply With Quote
Old 01-08-2019, 04:20 PM   #5
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 4,362
If you do decide to replace capacitors, read up on discharging them before you attempt to remove the existing ones !!
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 01-08-2019, 04:20 PM   #6
Member
 
Mike Tomas's Avatar
 
Monaco Owners Club
Vintage RV Owners Club
Join Date: Oct 2017
Location: Arizona
Posts: 92
Sounds like a time-delayed transfer switch issue. ACs and general electrical loads should normally not be supplied for a a minute after the generator starts. Since you (if I'm reading this right) historically had to wait for the ACs to switch on, but now `sometimes` the front kicks in immediately, I'd recon that one leg of your transfer switch may be fused or the switch is otherwise faulty. You may have bigger issues than just starter caps.
Mike Tomas is offline   Reply With Quote
Old 01-08-2019, 04:24 PM   #7
Junior Member
 
Join Date: Dec 2010
Posts: 9
Thanks for the great info. An traveling for the next week. Will pursue when parked at site. There was always a delay of about 2 minutes before it would start after setting, it tries right away now but only sometimes. That makes it weirder. Rear air still has delay and starts fine. ???
Mistaya is offline   Reply With Quote
Old 01-08-2019, 04:39 PM   #8
Senior Member
 
Join Date: Sep 2018
Posts: 209
Quote:
Originally Posted by Mistaya View Post
Thanks for the great info. An traveling for the next week. Will pursue when parked at site. There was always a delay of about 2 minutes before it would start after setting, it tries right away now but only sometimes. That makes it weirder. Rear air still has delay and starts fine. ???
Does this happen when the A/C has already been running and you're changing over to gen power? If so, it's possible the compressed refrigerant has had the time to bleed down, which will lock up the compressor. Start current will be 4-8 times full load running current, which is fine for a quick blip, but not fine if sustained. The delay may be built into the roof A/C to ensure it's not short-cycled, locking up the compressor until it bleeds down. Your S&B systems will lock up, too, and trip out on their own internal protection (automatically resetting), but the utility generators aren't about to stall so no biggie.
KanzKran is online now   Reply With Quote
Old 01-08-2019, 05:19 PM   #9
Senior Member
 
Join Date: Oct 2016
Posts: 867
Quote:
Originally Posted by Mistaya View Post
Thanks for the great info. An traveling for the next week. Will pursue when parked at site. There was always a delay of about 2 minutes before it would start after setting, it tries right away now but only sometimes. That makes it weirder. Rear air still has delay and starts fine. ???
One of mine on a 5th wheel a few years did the same and it turned out to be a control board on the AC unit
__________________
2016 Tuscany 42GX
F150 KR or Escape Toad
lwmcguire is online now   Reply With Quote
Old 01-08-2019, 06:11 PM   #10
Senior Member
 
Join Date: Jul 2014
Posts: 15,555
To much current will trip a breaker, not enough power will stall out an engine.

Change the fuel filter on the generator before you start messing with the electrical system.
twinboat is offline   Reply With Quote
Old 01-08-2019, 06:22 PM   #11
Senior Member
 
TLGPE's Avatar
 
Join Date: Apr 2012
Location: CLEARWATER, FLORIDA
Posts: 980
You may be able to help some by turning the fans to "on" so that the fans start before the compressor tries to start. That reduces the starting load a little.

Further diagnosis is needed for a long term fix, but this may help a little.

Tom
__________________
Tom & Jan ---- Westwing43 (RVM28)
2008 NEWMAR MOUNTAIN AIRE 4528
Pulling a 2014 CHEVY CAPTIVA
TLGPE is online now   Reply With Quote
Old 01-08-2019, 07:13 PM   #12
Senior Member
 
Aegon's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Sep 2017
Location: NorCal
Posts: 457
I have this same problem on a houseboat w/10 kw generator. It only acts up in cold weather. My HVAC guy tells me it’s a slide valve sticking that locks up the compressor because refrigerant can’t flow. Can’t be 100% sure because we haven’t made repairs yet.
__________________
Alan
2018 New Aire 3343
DW Lilfoot
Aegon is offline   Reply With Quote
Old 01-08-2019, 09:46 PM   #13
Senior Member
 
Join Date: Jul 2014
Posts: 15,555
Quote:
Originally Posted by Aegon View Post
I have this same problem on a houseboat w/10 kw generator. It only acts up in cold weather. My HVAC guy tells me itís a slide valve sticking that locks up the compressor because refrigerant canít flow. Canít be 100% sure because we havenít made repairs yet.
A 10,000 watt generator is capable of over 80 amps. A locked compressor won't stall it before a breaker trips. If its gas and does it when cold, check the choke, if its warmed up, change the gas filter. If that don't work, clean the carb.
twinboat is offline   Reply With Quote
Old 01-09-2019, 01:10 PM   #14
Senior Member
 
Aegon's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Sep 2017
Location: NorCal
Posts: 457
Quote:
Originally Posted by twinboat View Post
A 10,000 watt generator is capable of over 80 amps. A locked compressor won't stall it before a breaker trips.
Good point, the generator breaker should trip before the engine gets drug down and stalls.

Thanks.
__________________

__________________
Alan
2018 New Aire 3343
DW Lilfoot
Aegon is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automotion windshield works sometimes, sometimes not? mickeysteele Class A Motorhome Discussions 1 08-10-2017 07:01 PM
Pulling a cargo trailer sometimes and a toad sometimes. dvmweb Toads and Motorhome Related Towing 6 10-13-2014 11:13 AM
Sometimes you're the windshield, sometimes the bug... JMonroe Just Conversation 15 06-08-2012 10:54 AM
Generator Kills My TV DCTENT Monaco Owner's Forum 7 07-30-2011 06:13 PM
cruise control sometimes works sometimes not ? fxdave MH-General Discussions & Problems 3 10-31-2010 11:12 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.