Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-26-2011, 09:56 PM   #1
Junior Member
 
Join Date: Mar 2011
Posts: 1
ABS Light

Does anyone have experience with an intermittent ABS light? Where I do start trouble shooting? The light was on for about half of my last 1700 mile trip. Sometimes it was on when I started the coach and then would go off an hour later. Other times it would come on in the middle of the day and stay on for several hours.

2005 Monaco Safari Cheetah. Cat C-7 350 HP, Allison transmission

Thanks
__________________

__________________
flyboy330 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-26-2011, 10:04 PM   #2
Senior Member
 
GMRHost's Avatar
 
Vintage RV Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: Jasper, Missouri
Posts: 339
It's generally a sensor that is out- and the front wheels are more suspect than the rears. But getting to cat & pulling codes might pinpoint it.
__________________

__________________
Tom - Retired OTR 20 years 2 million mile club - 1984 Diamond Maxi
I love everybody! Even some above ground!
GMRHost is offline   Reply With Quote
Old 10-26-2011, 10:11 PM   #3
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 5,563
This issue comes up a few times a year. I'm a bit foggy right now but do some searches and you will find a ton of information. In the mean time here is some fodder. I found on my 08 HR Endeavor that had intermittent issues with the light coming on which would also render my cruise control inop and drove me crazy.

I finally got the courage and used a pair of pliars to remove the front senders. My left one had a gob of grease on the end. The other was clean in the front. Prior to that I thought I found the problem by following the wires up and finding connectors that showed signs of water intrusion. Cleaning those and applying WD 40 did not resolve the issue. My senders on the front look like a T. The rears are only accesible by removing the wheels. Thank goodness I did not have to do that. I have not had an issue since removing and cleaning the fronts.

This said I believe there have been issues with plugged fuel filters. Somehow the engine, transmission and abs all talk together and the systems must thing the traction is bad if the engine is not reaching its full potential.

One cannot argue with success. So do some Searching on the forums. Go to RV.net too and search there.
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2012 Ford Edge Limited FWD 3.5L
Aluminator tow bar, Demco base plate
YC1 is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS light on due to frayed wire Indy Itasca Workhorse and Chevrolet Chassis Motorhome Forum 3 08-25-2011 06:11 PM
abs brake light came on today-safe to drive or not? lsu-kev Workhorse and Chevrolet Chassis Motorhome Forum 10 09-21-2010 10:25 AM
ABS light Foulwx Workhorse and Chevrolet Chassis Motorhome Forum 26 09-20-2010 08:17 AM
ABS & ATC light came on teddy1 Monaco Owner's Forum 7 08-05-2010 12:06 AM
Main Door Seal ABS Light Matt Dearing Alpine Coach Owner's Forum 5 01-12-2010 09:01 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.