Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-01-2012, 06:10 PM   #1
Junior Member
Join Date: Feb 2011
Posts: 8
ABS, no tail lights, shooting fuses

On a trip to Branson, our W22 Suncruiser had the ABS light come on and the cruise control quit. Then the tail lights quit working and the back up camera did some weird inversion thing. When we stopped for the night, my husband cleaned the sensors for the ABS. Started up next day and after a few minutes and applying the brake, ABS light on again, no cruise, no tail lights, no turning signals. After stopping again and park for night, he unhooked the toad, checked all bulbs, made sure sensors in good, and replaced several blown fuses. Stop brake fuse still shooting when applying brake sitting still. Any suggestions? We work on farm machinery all the time, but this has us guessing.

MAW8750 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-01-2012, 06:25 PM   #2
Senior Member
nightriderrv's Avatar
Fleetwood Owners Club
Join Date: May 2012
Location: NC
Posts: 1,678
Sounds like a dead short on the feed wire to the lights sounds like a wire rubbed raw and grounding popping the fuse when voltage applied
Mark Anderson - Nebo NC - western NC - RV Restoration tech - 9 Doggies - Outdoors person
1990 33ft Wilderness Cimarron 33X
nightriderrv is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.