Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 06-20-2016, 06:46 AM   #1
Join Date: Jan 2013
Location: Brandon, Fl
Posts: 93
Ace 30.1 on f53 chassis, no 12v to radio

We own a 2013 Ace 30.1, it has been a nice rig and we've enjoyed it. The radio went dead the other night as soon as I started the generator. I have no 12v to the radio from the battery. I am getting the 12v switched(battery disconnect is working....) I have checked fuses, but there has to be a fuse I'm missing somewhere....any suggestions?

Mrjim is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-21-2016, 07:19 AM   #2
Senior Member
Gormleys's Avatar
Winnebago Owners Club
Freightliner Owners Club
Join Date: Sep 2012
Location: CO
Posts: 568
You may want to ask this question over on the Thor owner thread. There are a lot of ACE owners over there. And I think there is a sticky with the electrical diagrams as well.
Colorado '15 Winnebago Forza 34T w/MKZ hybrid toad
Gormleys is offline   Reply With Quote

ace, chassis, f53, radio

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ace 30.1, no 12v to radio......HELP Mrjim Thor Industries Owner's Forum 2 06-23-2016 01:05 PM
Next Thor ACE challenge specific to the ACE, SOLAR! Forest Grump Thor Industries Owner's Forum 5 03-28-2015 10:23 AM
2013 Thor ACE vs 2015 Thor ACE ISURV8 Thor Industries Owner's Forum 6 09-11-2014 03:29 PM
Loss of 12v power to radio, 12v plugs, etc redeldo Monaco Owner's Forum 9 05-21-2008 04:34 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:24 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.