Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2014, 08:15 AM   #15
Senior Member
 
DegoRed's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2012
Location: Austin, TX
Posts: 716
Spent a bunch of time on the phone yesterday with Spartan & Ametek.

Spartan is basically worthless, all really nice and pleasent, just worthless with regards to help. They have no idea why the system is acting the way it is or what caused the problem or how to fix it. Spartan solution, buy a new guage for $385. My question, what if that does not solve the problem? Silence, they have no answer and no clue.

Ametek was very helpful. Who is Ametek you say? They are the manufacture of the guage, and the dash control panel that they refer to as a "light bar". Ametek say there should be no reason for unplugging the pressure sensor to cause a problem. They also confirmed what I already thought/knew, there is no way to put the plug back in crooked or cross ways, that it is a one way in one way out plug. Ametek also confirmed what I was thinking, that unhooking the power would not solve anything, since the unit does a self test everytime you turn the ignition on.

Ametek is basically stumped at this point, the tech guy I spoke with for about 1 hour did his very best to come up with a solution for me or an idea for a possible fix. Told me what error codes to look for and what could be possible things to check.

Here is the madness. Ametek sells a new guage for $65 +/-, however they can't sell one to me, has to go through one of their distributors. They gave me a list of distributors, of which I called them all. The distributors sell the guage for $105 +/-, however none have one in stock. Ametek has a policy where a distributor has a minimum purchase of 12 units, every single distributor told me this when I called. Went back and forth with Ametek over how does someone buy their product when they need one, such as myself, when none of the distributors have them, and they wont buy them due to your own purchase requirements? They are supposed to call me back with an answer, but never did yesterday.

I can buy the Ametek pressure sensor through Spartan for $385, which I may have to do if Ametek does not call me back today with a solution to work through their distributors.
__________________

__________________
2010 Fleetwood Discovery 40X
DegoRed is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-20-2014, 09:46 AM   #16
Senior Member
 
Join Date: Feb 2010
Posts: 4,492
May be time to call service shopscand wrecking yards.

You need to find another unit to swap.

Coukd be a bad connector that failed when you moved it.

Check the wires with a pin in the wire and ohm out to the connector pin.

Also possible for bad connection inside guage.

Ask guage manufacturer if you can send yours in for repair.
__________________

__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 05-20-2014, 10:11 AM   #17
Senior Member
 
DegoRed's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2012
Location: Austin, TX
Posts: 716
I did ask Ametek if I could send them the unit for testing, they said sure happy to do so. They did say that they don't usually do repairs, the units are cheap enough to just replace in lieu of labor time to repair, go figure.

I really don't mind spending the $105 assuming I can actually buy one, lol. But at $385 through Spartan it gives me pause to try others means.
__________________
2010 Fleetwood Discovery 40X
DegoRed is offline   Reply With Quote
Old 05-20-2014, 05:08 PM   #18
Senior Member
 
Join Date: Feb 2010
Posts: 4,492
But you do not know if yours is bad.

Can ametek provide a troubleshooting chart with voltage measurements or process to confirm meter is good or bad?
__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 05-25-2014, 07:29 PM   #19
Senior Member
 
DegoRed's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2012
Location: Austin, TX
Posts: 716
Fixed my guage issue, was a blown 5amp mini fuse. Doh!
__________________
2010 Fleetwood Discovery 40X
DegoRed is offline   Reply With Quote
Old 05-25-2014, 07:48 PM   #20
Moderator Emeritus
 
SarahW's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: In a lawnchair
Posts: 11,204
Quote:
Originally Posted by DegoRed View Post
Fixed my guage issue, was a blown 5amp mini fuse. Doh!
Excuse me, but... heehee. Glad you got it figured out, Dego.
__________________
.2012 Fleetwood Bounder 33C | 2012 Jeep Wrangler

SarahW is offline   Reply With Quote
Old 05-25-2014, 11:09 PM   #21
Senior Member
 
JFXG's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: May 2012
Location: Today? Mercer, PA
Posts: 3,614
Glad you got it fixed. Now quit screwin with stuff that ain't already broke!
__________________

__________________
John & Diane, Fulltimers. RVM103 NHSO
On the road since June '12 with Lincoln, the guard cat.
2002 Dutch Star 40, Freightliner, Cat 3126, 2004 Element
JFXG is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why do you like air leveling? Vanwill Monaco Owner's Forum 32 04-19-2014 08:41 AM
Two AirBag Springs & One 12V Air Pump. Possum RV Systems & Appliances 3 04-18-2014 06:37 AM
Air Dump micki49 Monaco Owner's Forum 19 04-14-2014 01:01 AM
Air Horn works low Psi but not full psi? hkindle Spartan Motorhome Chassis Forum 4 01-21-2014 08:46 AM
Charge Air Cooler hartk1 Alpine Coach Owner's Forum 10 10-21-2013 06:04 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.