Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-10-2015, 03:26 PM   #1
Junior Member
 
Join Date: Jun 2012
Posts: 3
Allison MT643 Neutral problem?

Hello Guys... Thanks in advance for your collective wisdom.
I have a '91 Gulfstream Friendship with a Cummins TD and Allison MT643.
Suddenly the rig wont turn over at all. It acts like a neutral problem. I have no ECU display or codes for clues. Batteries test 12.5V. The neutral switch is secure, and wires attached. My best clue may be that when I hit the starter, the Voltage meter drops to about 10, but engine does not turn at all. Voltage does not drop in any other drive position indicating neutral may be working. Any Ideas?
__________________

__________________
herkey43 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-10-2015, 04:41 PM   #2
Senior Member
 
Jake74's Avatar
 
Join Date: Jan 2015
Location: Hanceville,AL
Posts: 152
Have you tried turning the engine by hand to make sure it's not locked up?
__________________

__________________
Jake74 is offline   Reply With Quote
Old 07-10-2015, 04:52 PM   #3
Junior Member
 
Join Date: Jun 2012
Posts: 3
I have not, but will give it a shot. It has been running and starting fine daily. The only time it failed is when some guy was there who wanted to buy it.
__________________
herkey43 is offline   Reply With Quote
Old 07-10-2015, 05:36 PM   #4
Senior Member
 
Jake74's Avatar
 
Join Date: Jan 2015
Location: Hanceville,AL
Posts: 152
Quote:
Originally Posted by herkey43 View Post
I have not, but will give it a shot. It has been running and starting fine daily. The only time it failed is when some guy was there who wanted to buy it.
can you hear the starter click or anything when you turn the key.
__________________
Jake74 is offline   Reply With Quote
Old 07-10-2015, 07:39 PM   #5
Senior Member
 
ChasA's Avatar
 
Join Date: Mar 2007
Location: Apex, NC
Posts: 1,857
All seeing Karnak here. I see new chassis batteries in your future.
__________________
2010 Winnebago Journey Express 34Y
2010 Freightliner XCS (mfd 9/'09)
'07 Saturn Vue V6
ChasA is offline   Reply With Quote
Old 07-10-2015, 09:45 PM   #6
Senior Member
 
Join Date: Feb 2010
Posts: 4,492
Edit...reread op and below not your issue but good information.

Your voltmeter is dropping to 10 volts, at battery?

Confirm voltage at starting battery then work towards starter if voltage good at battery.

We have same tranny...me thinks...

4 speed.

Ours has a pneumatic shifter with push button control on dash.

Just crawl under the mh and look for the shifter on the passenger side of the tranny. ( if pusher)

It will have an actuator and box with wires.

Push the shifter actuator all the way in then pull it out one click.

All the way in should be reverse then out one click should be neutral.

(Just in case yours is backwards from ours and it does not work then pull out until stop then push in one click)

Not sure if it is adjustable but the neutral switch may be off by a bit or defective and you should seek a diagram to properly troubleshoot and chassis manufacturer is source.
__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 07-10-2015, 09:47 PM   #7
Senior Member
 
Join Date: Feb 2010
Posts: 4,492
BTW remember this as the shifter requires air to operate and if you shut engine off while NOT in neutral and the air drains from tank you cannot shift to neutral to start it.
__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 07-12-2015, 01:51 PM   #8
Junior Member
 
Join Date: Jun 2012
Posts: 3
Thanx TQ60, but I dont have an air setup. Just old school lever, back and forth. I need to get someone to go with me to test this some more, as suggested. I cant tell much from 30 feet away and all the dash buzzers going off.
__________________
herkey43 is offline   Reply With Quote
Old 07-12-2015, 02:26 PM   #9
Member
 
Join Date: Feb 2015
Posts: 34
If voltage at battery drops to 10v then it is not neutral switch. Either bad battery or starter. If you are dropping voltage, it is trying.
__________________

__________________
mn.roadking is offline   Reply With Quote
Reply

Tags
allison



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Allison MD3060 Transmission Shifter wheato22 Allison Transmission Forum 8 08-11-2015 09:11 PM
HWH Problem TsuSM70 iRV2.com General Discussion 6 05-23-2015 11:30 AM
Allison Throttle Position Sensor & PacBrake Problem jd956jd956 Allison Transmission Forum 13 04-29-2015 12:33 AM
Norcold frosting problem Navy Flier RV Systems & Appliances 3 02-22-2014 09:10 AM
Unusual Hydro Hot problem, and the fix Medico RV Systems & Appliances 0 02-14-2014 07:18 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.