Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-01-2015, 09:21 AM   #1
Junior Member
 
Thor Owners Club
Join Date: Jul 2011
Posts: 22
Also Atwood Furnace problem

Furnace will not lite.Solenoid keeps clicking but will not lite.Plenty of propane,fan & blower both work.Manual says ignition lockout fault.Have tried to reset but no luck.Any help would be appreciated.thank you.The model is an 8500 IV.
__________________

__________________
GeorgeH is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-01-2015, 09:26 AM   #2
Senior Member
 
Freightliner Owners Club
Join Date: Apr 2004
Location: Apache Junction, Az
Posts: 703
First, model number please.
Keeps clicking but will not lite. What does this mean?
My gas solenoid will turn on, I hear the furnace try to start (gas and ignition), but will not stay lite? See what I mean, about saying your words.
Sail Switch, Over temp switch, Igniter/flame sensor, Gas solenoid.
You could also goto the Atwood Website and get the manual and trouble_shooting doc. You could also call the tech support line.
But if you want help on any forums, you should start by being specific about what you hear and see, please. Best I can do with the info given
__________________

__________________
Dale&Susan, 08 Alfa Gold, DaGirlsRv Blog
2015 F-150XLT_1600W Solar_880 AmpHr
Magnum_MS2812
gatorcq is offline   Reply With Quote
Old 12-01-2015, 10:47 AM   #3
Senior Member
 
Join Date: Feb 2014
Location: KY
Posts: 1,151
Double check you propane leak detector. They need power to let the propane pass as a safe guard. Also try lighting a burner on your range and see if it lights and stays lit if that works chances are the problem is not in the propane system.
__________________
Brenda & AL
2017 Thor Venetian, T42
2017 Chevy Sonic, 2014 KTM 690 Duke
z3406 is offline   Reply With Quote
Old 12-05-2015, 11:40 AM   #4
Senior Member
 
FreedomDream's Avatar
 
Join Date: Aug 2012
Location: fulltiming
Posts: 294
First, check the intake and exhaust ports for wasp nests, spider webs and other critter debris that might be hindering air flow. If air is restricted, the sail switch will not close the circuit to allow the gas flow.
__________________
Bob & Joan Alexander, 2010 Tiffin Phaeton 36 QSH, 2013 Jeep Wrangler (toad)
Lobo & Juniper (woof, woof)
FreedomDream is offline   Reply With Quote
Old 12-05-2015, 09:32 PM   #5
Junior Member
 
BRYAN S's Avatar
 
Monaco Owners Club
Join Date: Jul 2012
Location: ODEM TEXAS
Posts: 24
Check the exhaust. I get the same problem and it's been mud dobbers in there.
__________________
2005 diplomat
2011 ford edge
blue ox tow bar and base plate
BRYAN S is offline   Reply With Quote
Old 12-06-2015, 06:48 AM   #6
Senior Member
 
Workhorse Chassis Owner
Join Date: Sep 2007
Location: st.charles mo.
Posts: 1,194
Most attwood heater problem are do to bad connections. Remove and reconnect every spade connector on the heater to improve the connection.
__________________

__________________
speed racer is offline   Reply With Quote
Reply

Tags
atwood, furnace, ace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Allegro (Atwood) Jack Wiring Problem mikefoye Tiffin Motorhomes Owners Forum 7 11-06-2015 08:11 PM
Atwood Levelegs Problem park_ridge_dave Newmar Owner's Forum 2 09-14-2015 08:26 AM
Atwood 8535 furnace & battery life Baldtbird.06 RV Systems & Appliances 2 05-12-2015 09:47 PM
Atwood Model 8531 Furnace Chaparral RV Systems & Appliances 26 02-23-2015 12:11 PM
Atwood & Suburban water heaters & Furnace "007" RV Systems & Appliances 1 08-07-2010 10:37 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.