Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-15-2015, 07:53 PM   #1
Junior Member
 
Join Date: Jul 2015
Posts: 7
ATC light

Endeavor 330 Cummins ISC . Has anyone had a ATC problem related to clogged fuel Filter ? The Cummins shop disagrees a clogged fuel filter will cause a problem with the ATC, i just had this problem and it was fixed with new fuel filters .
__________________

__________________
oscarsrv is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-15-2015, 07:59 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,972


There's been another post on ATC ( Auto Traction Control) where the member was asking what the acronym stood for , and several replies mentioned that , the light can be triggered by poor throttle response , due to plugged fuel filters.
The post may have been in the Monaco Forums. I'll track it down and link you to it.


EDIT: Found it.


ATC... What does it stand for?
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-15-2015, 08:07 PM   #3
Senior Member
 
Dupdyke's Avatar
 
Join Date: May 2012
Location: Roseville MN sum / La Feria Tx winter
Posts: 715
My isl 400 had a bad slug of fuel and it gummed up the filter It bucked and I was worried I had fuel rail issues since I had just changed both fuel filters. Took it to coach care and they checked atc system no issues and they put it a new fuel filter water separator and problems all went away.

Fuel delivery can give lots of weird issues.... good luck
__________________
Sheri & Don 2003 Dynasty 42" regal ISL 400
2007 Goldwing Trike Gmc 4X4 w/ autoloader for trike
Lets go we got it all loaded.
Dupdyke is offline   Reply With Quote
Old 08-06-2015, 08:28 AM   #4
Junior Member
 
Monaco Owners Club
Join Date: Feb 2014
Posts: 1
Rough start up and ATC engages during full throttle 330 ISC '03 Cummins Monaco

Quote:
Originally Posted by oscarsrv View Post
Endeavor 330 Cummins ISC . Has anyone had a ATC problem related to clogged fuel Filter ? The Cummins shop disagrees a clogged fuel filter will cause a problem with the ATC, i just had this problem and it was fixed with new fuel filters .
I started having two problems at the same time. I thought the two were separate issues, but now I am thinking they are related. My startup in the garage while moving and parking for load up preparations for my trip is not as like it was. It cranks a little longer and it sputters some for 5-10 seconds then is OK. I take off and the ATC engages during rapid acceleration the first time leaving the stop sign. It shutters and then every time I go up hills it engages and draws done my power some. I read up on it. (Automatic Traction Control) and found it is designed to both reduce torque to the wheel that is spinning and apply brakes. The brakes only apply below 25 mph. That made sense since It shuttered when I left the stop sign, but only slows slightly when climbing hills with out any shutter. I thought the rough start was probably a dirty filter and I would change them out after this trip. Now, I wonder if they are not related. I will report in later. THX for the posts IRV2 you have saved me several times already. Now it is time Blues at the Bayfront Blues Fest in Duluth, MN.
__________________
MinnesotaBob is offline   Reply With Quote
Reply

Tags
light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My ABS Light Story: ktoutoor Workhorse and Chevrolet Chassis Motorhome Forum 19 05-27-2016 05:33 PM
Rear tail light failure aeroquality Newmar Owner's Forum 1 07-05-2015 03:50 PM
How to replace the incandescent bulbs in your vanity light bars with LED bulbs spendingit Thor Industries Owner's Forum 2 06-27-2015 11:50 AM
2002 Monaco Diplomat ABS / ATC light - reset switch location? FLNavyVet Monaco Owner's Forum 8 01-07-2015 11:40 PM
Brake light function seperate turn signal lights. briankstan Winnebago Industries Owner's Forum 11 08-12-2014 09:08 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.