RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-20-2017, 08:00 AM   #1
Junior Member
 
Join Date: May 2016
Posts: 2
Atwood levelegs

I recently bought a 2005 bounder and have a problem with my atwood levelegs the drivers side rear was not working i took it off and discovered the gear box had stripped gears the atwood part# 66280 7.5k 15' is not available and thru research found that lippert now owns atwood but i need to know if lippert part # 678258 is a direct replacement for the atwood levelegs and will i need to reprogram the system to make it function correctly
__________________

Necb2016 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-20-2017, 08:52 AM   #2
Senior Member
 
Join Date: Mar 2011
Posts: 106
If you are talking about the main gears that are under the black box and not in the black box, I just replaced mine. I pulled the black box off the leg and the gears were all chewed up. I called limmpert and they sell a gear kit. It came with one gear a washer and a new shear pin. $30 ea. The gears in my black box were fine.
__________________

__________________
Dave & Debi 2007 Alfa See Ya Model 1007 40ft 3 slides. 330 hp Mercedes-Benz MBE 926 Towing a 1989 YJ Wrangler Jeep.
ddgoodtimes is offline   Reply With Quote
Old 10-20-2017, 09:54 AM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 39,487
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

Congrats on the new rig! Sorry I can't help with your problem. Keep her between the ditches!

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is online now   Reply With Quote
Old 10-20-2017, 11:56 AM   #4
Senior Member
 
DGBPokes's Avatar
 
Newmar Owners Club
Workhorse Chassis Owner
Spartan Chassis
Join Date: May 2010
Location: McAlester Ok
Posts: 1,805
Congratulations.....beware! We have a Newmar '07 KStar DP with Level legs. We've had this coach less than 3 years. I always had intermittent problems with the right front leg retracting. Last year the system quit working completely, all legs retracted, and a constant warning horn. A long story made short: The controller failed, obsolete, no salvage units, no dinosaurs boards. The fix.....replace the entire system, legs and all. Ridiculous!!! Newmar got me a deep discount on the entire system. $2500 for the system $1,000 for the installation. The new system is a much better design. It is much slower, levels more accurately, and has been dependable.
My advice: 1. Old system can be hard rebooted, do so once a year, just to keep it "clean". 2. Be very, very patient when operating. Let if totally complete what it is doing before you touch another button. 3. Never, never let anyone else operate the system. I had let a body shop clear coat my front top cap, I think they tried to hoist the rear, drop the front, and finally fried the the thing.
__________________
2007 Newmar KSDP. 3912
2010 Nissan Frontier SE
DGBPokes is offline   Reply With Quote
Old 01-30-2019, 08:40 PM   #5
Senior Member
 
Powerstroke2000's Avatar
 
Join Date: Mar 2002
Location: B.C., Canada
Posts: 100
Quote:
Originally Posted by DGBPokes View Post
Congratulations.....beware! We have a Newmar '07 KStar DP with Level legs. We've had this coach less than 3 years. I always had intermittent problems with the right front leg retracting. Last year the system quit working completely, all legs retracted, and a constant warning horn. A long story made short: The controller failed, obsolete, no salvage units, no dinosaurs boards. The fix.....replace the entire system, legs and all. Ridiculous!!! Newmar got me a deep discount on the entire system. $2500 for the system $1,000 for the installation. The new system is a much better design. It is much slower, levels more accurately, and has been dependable.
My advice: 1. Old system can be hard rebooted, do so once a year, just to keep it "clean". 2. Be very, very patient when operating. Let if totally complete what it is doing before you touch another button. 3. Never, never let anyone else operate the system. I had let a body shop clear coat my front top cap, I think they tried to hoist the rear, drop the front, and finally fried the the thing.
Oh my, that's terrible! I see this is an older post, but thought I'd ask what you meant by 'Hard Rebooted'?? Haven't heard of this before, so I thought I'd ask. I'm having an odd issue, where my jacks moved down to the ground, then they move up 1/2" off the ground (all 4). I'm unsure what I can do to correct this, as I've had some issues of when pushing the 'On' button, getting it to actually turn on! If I push it quite hard, it started up today...but again, they're left a 1/2" from the ground, so no jacks pushing upward to level my rig!
__________________
2008 Tiffin Phaeton - ISC Cummins
2014 Honda CRV (Towed) & Air Force one braking system.
Powerstroke2000 is offline   Reply With Quote
Old 01-31-2019, 07:20 AM   #6
Senior Member
 
Join Date: Nov 2012
Location: Keeseville ny
Posts: 601
I would like to no what a hard reboot is also.
cwit is offline   Reply With Quote
Old 01-31-2019, 07:34 AM   #7
Senior Member
 
frede's Avatar
 
Join Date: Dec 2010
Location: Fort Washington, MD
Posts: 217
Quote:
Originally Posted by Powerstroke2000 View Post
...I'm unsure what I can do to correct this, as I've had some issues of when pushing the 'On' button, getting it to actually turn on! If I push it quite hard, it started up today...but again...
I also had a button problem so I called Lippert at (574) 537-8900 and eventually ended up at sales talking to a nice lady named Janet. She said they have plenty of new Atwood 66273 Touch-pads for $172, but no controllers. When it got here I was a little concerned because the part number was 66555 not 66273 and there was a jumper cable (Part No. 66557) so I called Lippert and they assured me it was the newer updated touch-pad. The new one works great. The buttons have a much better feel and it only takes one press to get them to work.
__________________
Fred Edelkamp, USAF Combat Camera Retired driving Betsy - 2004 Fleetwood Flair 33R F53 6.8 V10 20.5K | Samson 245/70R19.5 | CHF | Bilstein HD | Safe-T-Plus | 5 Star Tune | TST | Blue Ox Alpha Autostop | 2006 Jeep Wrangler TJ | 2009 Hyundai Accent hatchback
frede is online now   Reply With Quote
Old 01-31-2019, 11:34 AM   #8
Senior Member
 
DGBPokes's Avatar
 
Newmar Owners Club
Workhorse Chassis Owner
Spartan Chassis
Join Date: May 2010
Location: McAlester Ok
Posts: 1,805
Greetings
Per a phone call with Atwood. They recommended disconnecting all the wires and reconnecting including the level sensor located under the coach. They also cautioned that it should be accomplished on a lift, or in a pit since the system would be likely to dump air and crush you while under it.
When the tech had bypassed our failed controller, he had a young helper start to back the rig out of the shop. The unit dumped.....scared the kid bad.
__________________

__________________
2007 Newmar KSDP. 3912
2010 Nissan Frontier SE
DGBPokes is offline   Reply With Quote
Reply

Tags
atwood



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Levelegs system DandS Newmar Owner's Forum 33 09-17-2012 10:18 PM
Atwood Levelegs millerdp MH-General Discussions & Problems 1 08-25-2010 03:56 AM
Atwood Levelegs Electric Jack System Failed - UPDATE GerryB54 Fleetwood Owner's Forum 18 06-25-2009 09:26 AM
Atwood Levelegs rbuddy Newmar Owner's Forum 2 09-27-2008 06:07 PM
Atwood LeveLegs... RobbieR Workhorse and Chevrolet Chassis Motorhome Forum 2 04-23-2007 08:53 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×