Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 02-17-2014, 09:52 AM   #1
Join Date: Dec 2013
Posts: 57
Atwood levelers

I'm looking buying a 2008 Tiffin Phaeton with Atwood levelers should this be a concern? Ty

Captainkoop is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-17-2014, 08:24 PM   #2
Engle's Avatar
Tiffin Owners Club
Join Date: Apr 2013
Location: Gods Country, Alabama
Posts: 84
I have a 2006 Allegro Bay with Attwood levelers. They work perfect.

Engle is offline   Reply With Quote
Old 02-17-2014, 08:29 PM   #3
Community Administrator
NLOVNIT's Avatar

Pond Piggies Club
Fleetwood Owners Club
Ford Super Duty Owner
LA Gulf Coast Campers
Outdoors RV Owners Club
Join Date: Mar 2002
Location: Central OH, USA
Posts: 18,626
Blog Entries: 1
2006 Bounder w/Atwood. No issues.

Lori & Dave - FMA #3415 | FMCA #F419886 | RV/MH Hall of Fame Lifetime Member
2006 Fleetwood Bounder 36Z & 2014 Honda CRV AWD, My iRV2 Photo Albums
How is it one careless match can start a forest fire but it takes a whole box to start a campfire?
NLOVNIT is offline   Reply With Quote
Old 02-18-2014, 01:13 PM   #4
Fleetwood Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2010
Location: Peoria, Illinois
Posts: 46
2006 Vacationer with Attwood levelers with no problems
2015 Fleetwood Terra 2008 HHR toad
Retired and loving it :
KenM is offline   Reply With Quote
Old 02-18-2014, 02:44 PM   #5
Senior Member
Join Date: Sep 2009
Location: Central Indiana
Posts: 261
I have a 2006 that I have had to replace the main power control 4 times. My understanding is that Atwood no longer makes this controller; their answer is to replace jacks and all with their new system. The problem is the tiny 4 pin connector on the end of the cable that feeds the front panel. The flimsy pins corrode causing loss of control signals to the front panel. If I ever have to replace the leveling system, I will go with HWH.
mrboyer is offline   Reply With Quote
Old 02-19-2014, 02:25 AM   #6
Senior Member
Join Date: May 2010
Posts: 247
Our Pace has Atwoods. Overall, I think it's a good system, BUT...there are a few things to check due to the way that Fleetwood installed the system.
I lost a jack and a main control board, the jack was probably due to the control board.

The control board (not the operator panel, but the board that connects to) is mounted in the far left corner under the dash on our unit. It is a circuit board that is roughly 4" x 6". The 6" side is mounted flush against the wall on the driver's side, with the 4" side mounted to the firewall. The connectors from the jacks all connect on the 6" side.
Because it is mounted "flush", condensation can run down the outside wall and collect in the little tray that the circuit board is mounted on. When a jack went bad it was from continously running after a full retract, and it stripped the gears. The jack system started acting a bit flakey, and I ended up pulling the board and saw corrosion on the connectors. When I disassemble the board/tray assembly, it was clear that water had been trapped in the tray, and the entire underside of the circuit board was corroded so some of the solder joints were bad. This was causing numerous intermittent issues with the system.
Very easy to fix...take the screws out that mount the board to the wall/firewall, get longer screws, and install a nut or similar spacer between the tray and the wall when reinstalling. This gives approx. 1/4" gap between the tray and the wall, so if water DOES run down the wall, it will just pass the tray and go straight to the floor.

If you crawl under the dash with a flashlight, you can examine the connectors going to the module for corrosion, and you'll have a good idea if there's a problem. If there's signs of corrosion, walk away, since Atwood doesn't make that board anymore.
If there are NO signs of corrosion, I'd make the mod anyway, just in case.
We've never had a problem with condensation in the unit, but apparently the previous owners did. I got lucky and found the part by doing a google search. Some guy in the midwest had one, and had no idea what it was...he'd bought a bunch of parts from an RV shop that went under, and had listed them for sale on his website.

Hope this helps.

Lobstah is offline   Reply With Quote
Old 02-19-2014, 08:49 AM   #7
Senior Member
Join Date: Apr 2010
Location: Where we park
Posts: 161
My 2005 Southwind Atwood leveler have worked perfect 8 years and 70k miles. full-time since 2008
Harry & Becky
2005 Southwind 32vs F53
2006 Liberty
3wheeljunkie is offline   Reply With Quote
Old 02-19-2014, 06:06 PM   #8
Join Date: Dec 2013
Posts: 57
Thank to all for great responses.

Captainkoop is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Furnace Fan Chuck&Pam RV Systems & Appliances 6 02-15-2014 02:38 PM
Atwood 5th Wheel Hitch Blue74 Trailer Towing and Tow Vehicles Discussion 2 02-13-2014 09:19 PM
Kwikee Levelers / Dexron III Question RTegarini Winnebago Industries Owner's Forum 5 07-09-2013 06:44 AM
Big Foot Levelers Not Responding - Happy Ending jnp_macklin Class A Motorhome Discussions 2 06-03-2013 09:03 AM
Atwood & Suburban water heaters & Furnace "007" RV Systems & Appliances 1 08-07-2010 09:37 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:42 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.