Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-02-2015, 01:55 PM   #1
Member
 
Monaco Owners Club
Join Date: Oct 2009
Posts: 34
Atwood water heater won't stay lit on propane

I use the switch on the inside panel. The electronic ignition water heater tries to ignite three times and the default light comes on. Thinking it might be the burner, I have cleaned the orifice and flue to no avail. Any suggestions?
__________________

__________________
rambler05 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-02-2015, 04:04 PM   #2
Senior Member
 
Monaco Owners Club
Freightliner Owners Club
Join Date: Mar 2015
Posts: 166
water heater

i trouble with mine after i took it apart to clean i apparently bent the mount and the flame censer was out of place once i got it back in the flame all was good hope this helps mike
__________________

__________________
lead follow or get out of the WAY
1998 HR Endeavor 5.9 Cummins
redtail is offline   Reply With Quote
Old 05-02-2015, 05:19 PM   #3
Senior Member
 
Damon Owners Club
Join Date: Dec 2013
Location: Atlanta GA
Posts: 168
Mine did that and it had corrosion on some of the wiring connections. Cleaned and scuffed up the connectors and put Dielectric grease on connections and all is good.
__________________
Class A, Koni shocks, Safe T Plus, SuperSteer Rear Trac Bar, CHF.
hdzcar is offline   Reply With Quote
Old 05-02-2015, 05:27 PM   #4
Senior Member
 
Join Date: May 2013
Location: Aransas Pass, TX
Posts: 251
Go HERE to look at the Atwood troubleshooting guide. BryantRV has manuals for all sorts of RV systems.
__________________
HoneyBadger is offline   Reply With Quote
Old 05-02-2015, 08:02 PM   #5
Senior Member
 
Join Date: Jul 2007
Posts: 678
Strongly advise grabbing the Atwood service manual that HoneyBadger pointed you to. Keep a copy handy. Your water heater will start on about page 15. Three or four pages later the trouble shooting section starts. Try it, you will like it.
__________________
Pete - Full Timing
2000 Country Coach Magna 40', CAT C10, #5892
2006 Jeep Liberty
phays is offline   Reply With Quote
Old 05-04-2015, 08:34 AM   #6
Senior Member
 
Join Date: Dec 2014
Posts: 151
I had the same problem ,cleaned all the connections,ended up being the circut board ,
__________________

__________________
Mr Plymouth is offline   Reply With Quote
Reply

Tags
atwood, heater, water heater, water, propane, heat



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrading Atwood water heater to gas/elec model ?? Karlos National RV Owner's Forum 8 03-20-2015 05:44 AM
Atwood Water Heater Gas Valve Solenoid Tip rockintom Excel Owner's Forum 4 02-14-2015 02:45 PM
Atwood water heater noise when on 110v AC chief02 Excel Owner's Forum 28 11-14-2014 03:51 PM
atwood water heater clog ganic 5th Wheel Discussion 2 08-30-2014 12:05 PM
Atwood g6a-8e water heater question gazingm42 Travel Trailer Discussion 2 07-10-2014 09:01 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.