Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-23-2015, 03:37 PM   #1
Junior Member
Damon Owners Club
Join Date: Feb 2015
Posts: 11
Back up camera

I cannot believe that I am the only one that has ever experienced this. I purchase a use 2003 Damon Ultrasport with less than 50k on the odometer. Everything works great except the back up camera system. I replace the monitor (purchased from RV cams) and have been working with RV cams out of Biloxi, MS. The have been great, except I still cannot get it to work. It seems the system does not want to operate in my RV. I have gone so far as connect it directly with a short coupled camera to the battery, confirmed the voltage to the unit at 13 VDC, and get no signal or only a snow storm with a focal length of about 1'. I can take the monitor, camera and alligator clips and attach it to my pick-up and it works fine. RV cams has checked the camera, and it is fine. As I stated previously. all 12 VDC systems in the RV work great. Been fighting this since April. Any ideas?

ALF1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-23-2015, 04:30 PM   #2
Senior Member
BFlinn181's Avatar

Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 12,654
You'll need to test that the 12 v power and ground is going to the camera. Also, the video signal should be checked. It's usually a single wire surrounded by shielding ground wire. Also check where the camera gets it's 12 v. Some are only powered when the transmission is put in reverse. This power could come from a switch on the transmission, shifter, or even from the back up lights.


Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 10-23-2015, 04:44 PM   #3
Senior Member
Tiffin Owners Club
Freightliner Owners Club
Join Date: Aug 2014
Posts: 1,673
The OP says his system works fine in a "Bench Test" mode.
Monitor and display connected with a short cable works fine in his Pick-up truck.

Let's keep it simple....take the EXACT same setup (don't switch cables) and connect it to 12v in the RV (maybe directly to the battery. If that does not work, you have a problem with your 12v source in the RV. Also, you have two 12V systems in the RV, try both of them.
It should work if you connect directly to the RV battery.
Then change one thing...connect to the 12v in the dash.
Keep going by only changing one thing at a time.

As Bob said, it is likely one of the two cables that go to the back camera housing.

Good Luck..

2014 40QBH Phaeton DP Cummins 380HP ISL, Freightliner XC, 2014 Jeep Trailhawk TOAD
Blue Ox Aventa tow bar, SMI Air Force One -South Orange County Ca.
dpinvidic is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with back up camera wiring TimLoon Technology: Internet, TV, Satellite, Cell Phones, etc. 6 09-01-2015 06:05 PM
Back up camera sc3020 Class A Motorhome Discussions 5 08-18-2015 11:57 AM
Back up camera 2016 Entegra FreshAir Entegra Owner's Forum 17 08-17-2015 11:05 AM
Back Up Camera Upgrade Sky Pilot RV Systems & Appliances 3 06-03-2015 11:05 AM
Wireless back up camera for pull trailer ian pelham Travel Trailer Discussion 18 05-24-2014 12:12 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:09 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.