Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2011, 07:56 PM   #1
Member
 
dspowers's Avatar
 
Vintage RV Owners Club
Appalachian Campers
Join Date: Apr 2011
Posts: 48
Backfire! Kohler Generator

I replaced my fuel pump on generator, after adjusting the fuel mixture with the shut-down control removed the gas flow seems to be correct until I put the air filter on, the carb seems not to breath and backfires with black smoke!! what am I doing wrong?
__________________

__________________
dspowers is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-10-2011, 01:05 AM   #2
Senior Member
 
W4RLR's Avatar
 
Appalachian Campers
Join Date: Jan 2007
Location: Sewanee, Tennessee
Posts: 713
Send a message via Yahoo to W4RLR
Quote:
Originally Posted by dspowers View Post
I replaced my fuel pump on generator, after adjusting the fuel mixture with the shut-down control removed the gas flow seems to be correct until I put the air filter on, the carb seems not to breath and backfires with black smoke!! what am I doing wrong?
When the air filter gets put on, it restricts the air flow to the point that the generator runs rich. That explains the backfire and poor performance.

Can you adjust with the air filter ON the carb?
__________________

__________________
SSgt. Richard L Ray, USAF (Retired) - Laura L Ray
Our second home is a vintage 1995 Jayco Eagle 277RB 'The Love Shack"
towed by a 2008 Ford F-250 Lariat Crew Cab short bed "The Green Goblin"

[SIGPIC][/SIGPIC]
W4RLR is offline   Reply With Quote
Old 05-10-2011, 06:45 AM   #3
Registered User


 
Monaco Owners Club
Join Date: May 2009
Posts: 3,198
While I agree with the poster above, I'd also find it real unusual that a proper air filter would make such a difference?

Is there something wrong inside the air filter, a restriction of some sort?
Is it interfering with some linkage when you put it on, perhaps closing a choke or something?
__________________
JimM68 is offline   Reply With Quote
Old 05-10-2011, 10:09 PM   #4
Member
 
dspowers's Avatar
 
Vintage RV Owners Club
Appalachian Campers
Join Date: Apr 2011
Posts: 48
The generator is running very rich I adjusted idle fuel mixture screw 1-1/4 turns out and engine does not start, unless I turn idle fuel screw back down, but it seems that the engine is running hard, it stays started but there is gas shooting from carb. When I put the shut-down solenoid back it does not start at all. After it runs for about 3-5 min seems like it less gas shooting from carb, my fear is the gas shooting from carb. What should I do to fix this problem myself $$$$
__________________
dspowers is offline   Reply With Quote
Old 05-10-2011, 10:18 PM   #5
Senior Member
 
Join Date: Feb 2010
Posts: 4,492
Float is not seating and allowing rich condition.
__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 05-10-2011, 11:22 PM   #6
Senior Member
 
LVJ58's Avatar
 
Join Date: Jul 2000
Location: Las Vegas, NV
Posts: 2,146
sounds like the float level may be off and doesn't close the needle valve completely when fuel bowl is full and excess fuel getting sucked into the venturi resulting in rich mixture.
__________________
Jim & SherrySeward

2000 Residency 3790 v10 w/tags 5 Star tune & Banks system Suzuki XL7 toad
LVJ58 is offline   Reply With Quote
Old 05-11-2011, 02:04 AM   #7
Member
 
dspowers's Avatar
 
Vintage RV Owners Club
Appalachian Campers
Join Date: Apr 2011
Posts: 48
How do I adjust the float level, I have the owners manual but nothing about the float only the carb,choke and governor. Which of these controls the float?
__________________
dspowers is offline   Reply With Quote
Old 05-11-2011, 06:53 AM   #8
Member
 
Join Date: Jan 2011
Location: Right Now: San Diego, California
Posts: 41
Quote:
Originally Posted by dspowers
How do I adjust the float level, I have the owners manual but nothing about the float only the carb,choke and governor. Which of these controls the float?
As stated the needle may not seating.

Does fuel leak or drip from the carb when not running? It's a clear indication of the issue at hand.

Depending on clearances you may have to remove the carb.
Remove the fuel bowl followed by the float then needle and inspect for any gummed up gas or debris on the needle and where it seals up against in the carburetor.

With it not sealing properly the bowl overfills with fuel and gets sucked through the overflow tube and into the carb causing your rich mixture.
__________________
Mark '91 Alexxa 28' Isuzu 4cyl turbo diesel
10.5-12mpg towing a honda civic
http://www.OneLoveRV.com
GreaseMonkey is offline   Reply With Quote
Old 05-11-2011, 02:58 PM   #9
Senior Member
 
bigskymt's Avatar
 
Newmar Owners Club
Join Date: Apr 2010
Posts: 462
With the generator running tap on the side of the carb. with a small hammer or screwdriver handle, this should free up the float. Onans were notorious for float/needle&seat problems. Either dirt or a groove worn into the needle will prevent it from seating properly and cause flooding. I've seen some needles with a neoprene base that wears on the seat and refuses to seal properly. Not sure if this was Onan or an aftermarket part. They also had a problem with their float: some were porous and would actually absorb gas and sink thus opening the seat. Others were brass and would leak around the soldered union and also sink.
__________________
bigskymt is offline   Reply With Quote
Old 05-11-2011, 04:24 PM   #10
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,382
Did you buy the fuel pump from kohler? It sounds like you have a fuel pump that is putting out way too much pressure. Just because it is the same type and make pump, Does not mean the pressure is right.
__________________

__________________
ga traveler is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote generator start not working, please help ShapeShifter Monaco Owner's Forum 20 08-24-2016 12:05 PM
Kohler 4CM21 generator Planemech RV Systems & Appliances 9 12-03-2010 01:25 PM
Generator only putting out a few volts AC TallPaul RV Systems & Appliances 7 12-25-2007 03:57 PM
Generator Coolant Level OldForester Alpine Coach Owner's Forum 8 10-25-2007 06:56 AM
Generator wont start (or even crank) Problem. SouthernGypsy MH-General Discussions & Problems 26 07-13-2007 09:16 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.