Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-19-2014, 07:27 PM   #1
Senior Member
sgtjoe's Avatar
National RV Owners Club
Join Date: May 2008
Posts: 1,725
Bad Generator Radiator Cap

Just wondering if a bad radiator cap could cause a generator to shut down in under 3 min? My Generac 75D shuts down within a few mins with the radiator cap on, but if I run it without it lasted 15 mins with one a/c running. I shut it down. Anyone ever had this happen???

Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-20-2014, 07:01 PM   #2
Senior Member
Dtwallace's Avatar
Join Date: May 2014
Posts: 808

I'm thinking unless you've verified this is in fact the cap being an issue, the shut down is being caused by something else.

I'd first look at the gen set engine oil level.

Be sure you have enough fuel to support running the gen set, don't know if that will effect your coach as it does mine.

Be sure you have a full radiator, you may have a coolant level shut down switch also.

These are just guesses on my part, other than an electrical out put problem I'm lost. Hope you find your fix with one.

Dan & Loretta, US Army Retired Aero Scout Pilot
2012 Fleetwood Providence 42P Class A/DP
Spartan Chassis, 8.9L Cummins 450HP
Dtwallace is offline   Reply With Quote

generator, radiator

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tires, TPMS and what is bad? raroberts Trailer Towing and Tow Vehicles Discussion 5 04-10-2014 09:31 AM
Bad Water Pump (engine) RufussSewell Class A Motorhome Discussions 4 01-09-2014 08:43 AM
The bad part of fulltiming? Tom222 Full-Timers 40 12-08-2013 10:21 AM
Good & Bad products for Septic Systems wingnutz iRV2.com General Discussion 10 06-12-2013 09:32 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:21 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.