RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-02-2017, 12:32 PM   #1
Junior Member
 
Join Date: Mar 2017
Posts: 4
Banks powerpac boost problems

I have a 1999 isb275 hp Cummings in a Fleetwood Discovery 37'. The engine has a Banks Powerpac on it. It is sluggish for the first 10 seconds at full throttle. It takes 20 seconds to get to 45 mph. I don't think this is normal, but I am new to Rvs and diesels. Once boost starts to build, maximum 28 lbs and 700 egt. Banks no longer services the computer. I'm at a loss as to how to get a quicker takeoff speed. I'm considering removing the banks, but not sure what my options are. Any suggestions?
__________________

Silverado58k is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-02-2017, 11:45 PM   #2
Senior Member
 
DD788Snipe's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2013
Location: Apple Valley CA
Posts: 1,066
Have your turbo checked. Could be a faulty waste gate. Just a guess.
__________________

__________________

Craig & Carolyn Roberts Apple Valley, CA
2006 Newmar 3910 KSDP 400 ISL Cummins Spartan Mountian Master Chassis
Toad: 2017 GMC Canyon 4X4 Crewcab
DD788Snipe is offline   Reply With Quote
Old 07-03-2017, 10:20 AM   #3
Senior Member
 
OLYLEN's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 2,751
Check the intake and boost air system. Most likely a leak. Or maybe exhaust brake needs lube. If it eventually gets the boost sounds like it needs to over run a leak.

LEN
__________________
2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Old 07-04-2017, 04:07 AM   #4
Junior Member
 
Join Date: Mar 2017
Posts: 4
Quote:
Originally Posted by DD788Snipe View Post
Have your turbo checked. Could be a faulty waste gate. Just a guess.
I had the turbo rebuilt by Arkansas Turbo. The wastegate has a banks bighead actuator. I'm pretty sure the wastegate is clamped shut.
Silverado58k is offline   Reply With Quote
Old 07-04-2017, 04:13 AM   #5
Junior Member
 
Join Date: Mar 2017
Posts: 4
Quote:
Originally Posted by OLYLEN View Post
Check the intake and boost air system. Most likely a leak. Or maybe exhaust brake needs lube. If it eventually gets the boost sounds like it needs to over run a leak.

LEN
I replaced a rubbed hose and the oring gasket on the pressure side of the boost. I'm 99 percent sure there's no leaks, but your not the first person to say it may have a leak.
Silverado58k is offline   Reply With Quote
Old 07-04-2017, 08:13 AM   #6
Senior Member
 
Spartan Chassis
Join Date: Aug 2015
Location: SW, MO
Posts: 162


I really don't think getting to 45mph in 60 seconds is real slow.
The first thing to do if you have low power is to change your fuel filters. If you get a bad tank of fuel they may have to be changed more than once.
Do you have a fuel pressure gauge?
Your MH is a 1999 model so you probably have a "CAPS" injection system. Loss of fuel or low pressure will cause major problems if not fixed quickly. Look for a thread called "Repeating CAPS failures-need help" in the Cummins engine forum. There is a lot of information in that post.
__________________
Happy Motoring
Don Susan
2000 Newmar DSDP 3894, Cummins 330, Spartan, MM,
2004 Pilot toad
4Fingers is offline   Reply With Quote
Old 07-05-2017, 07:12 PM   #7
Junior Member
 
Join Date: Mar 2017
Posts: 4
Quote:
Originally Posted by 4Fingers View Post


I really don't think getting to 45mph in 60 seconds is real slow.
The first thing to do if you have low power is to change your fuel filters. If you get a bad tank of fuel they may have to be changed more than once.
Do you have a fuel pressure gauge?
Your MH is a 1999 model so you probably have a "CAPS" injection system. Loss of fuel or low pressure will cause major problems if not fixed quickly. Look for a thread called "Repeating CAPS failures-need help" in the Cummins engine forum. There is a lot of information in that post.
I just changed all the fuel filters and oil filter. My problem is low boost on takeoff. Maximum boost is 28 lbs. and maximum exhaust gas temperature is 700 degrees. Never any black smoke on takeoff. I'm told I'm not getting enough fuel, but not sure where to take my coach. Anyone have experience with a Banks Powerpac System?
Silverado58k is offline   Reply With Quote
Old 07-05-2017, 10:43 PM   #8
Senior Member
 
DD788Snipe's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2013
Location: Apple Valley CA
Posts: 1,066
You may need to install a high volume lift pump.
__________________

__________________

Craig & Carolyn Roberts Apple Valley, CA
2006 Newmar 3910 KSDP 400 ISL Cummins Spartan Mountian Master Chassis
Toad: 2017 GMC Canyon 4X4 Crewcab
DD788Snipe is offline   Reply With Quote
Reply

Tags
ems, power, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
C7: Phantom "Low Boost" and "No Boost" Codes ProjectPro Caterpillar Engine Forum 6 12-22-2016 12:20 PM
Video Switchbox / Converter Box Hookup - To boost or not to boost? Planocat Newmar Owner's Forum 3 05-19-2015 05:26 PM
Turbo Boost What is the Maximum Boost that a 5.9, 275HP shogun1940 Cummins Engines 10 11-30-2014 07:47 PM
Boost/no boost JDD Cummins Engines 16 11-09-2014 08:01 AM
Banks Power Boost azbaroness MH-General Discussions & Problems 16 07-25-2009 10:37 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.