Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-17-2011, 08:35 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 8
Battery Disconnect

I own a Damon Intruder (2006)., The battery disconnect switch indicator light is red, and will not turn off when i try setting it for storage. I am assuming its the disconnect itself. There are supposed to be 2 fuses on it, but i am not sure where to locate the disconnect itself to check it. Does anyone know where it would be in this model?
__________________

__________________
ricklap is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-18-2011, 03:20 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
There is a black plastic cover attached to the compartment (compartment location varies) wall held by several 3/8" hex head tec screws. Behind the cover you will find the disconnect. It is a KIB brand and not a Intellitec. Good luck and .
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 03-20-2011, 04:41 PM   #3
Member
Commercial Member
 
Join Date: Apr 2009
Location: Panama City Beach, Fl.
Posts: 52
Verify that your RV is not plugged into shore power when using the battery disconnect, because the light will remain on because the converter will back feed to the light causing it to remain on while plugged in.
__________________
RV Trax is offline   Reply With Quote
Old 03-21-2011, 01:24 AM   #4
Junior Member
 
Join Date: Jan 2011
Posts: 8
Thanks for the info. I'll check inside the battery compartment for the disconnect. Hoping that's where it is I did note that the ligh came on when i ran the generator, so that could be why. All i know is i get no power to the dash board when i try to start it
__________________
ricklap is offline   Reply With Quote
Old 03-21-2011, 02:45 AM   #5
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
You will have a mechanical disconnect switch for the chassis.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 03-22-2011, 01:12 AM   #6
Junior Member
 
Join Date: Mar 2011
Posts: 28
I have a simular problem with my 2005 Fleetwood Southwind 32v. I do not have a light to indicate the connection however I can not get the main battery to disconnect. In the past I have had to push the disconnect switch several times before it would work, now it is not working at all, and the main battery remains connected. Any ideas how I can figure out where the problem is. When the switch did work I could hear a click near the dash on the drivers side so I am guessing the actual disconnect is up there even though the switch I push is over the door. The RV does have the Intellitec 900 power management system, but I am not sure if that has anything to do with it. Thanks in advanced for any help.
__________________
GoBigGuy is offline   Reply With Quote
Old 03-22-2011, 07:05 AM   #7
Registered User


 
Monaco Owners Club
Join Date: May 2009
Posts: 3,198
Your southwind probably has an RV Custom Products DC load center under the front hood. In my pace arrow it was high on the drivers side, directly in front of the driver. Square box with a removable cover on the front, a circuit board full of fuses and 3 big soldenoids inside, buncha big red wires going into it.
Can you find that?
__________________
JimM68 is offline   Reply With Quote
Old 03-22-2011, 09:46 AM   #8
Junior Member
 
Join Date: Mar 2011
Posts: 28
Jim, That is exactly where the click sound comes from when I push the disconnect and it actually works. I will get over to the RV this afternoon and look under the hood. Anything in particular I am looking for assuming I find it?
__________________
GoBigGuy is offline   Reply With Quote
Old 03-22-2011, 11:18 PM   #9
Junior Member
 
Join Date: Mar 2011
Posts: 28
I sent an email to fleetwood customer support and got the response below, very helpful information for other Fleetwood owners.

The battery disconnect solenoid is located in the battery control center
behind the PC board. The battery control center is in front of the coach
under the hood. There are two solenoids in there one is for the chassis
disconnect and the other is for the aux disconnect. Someone will have to
diagnose to see if the solenoid is bad or if you have a loose connection
somewhere in the circuit. We are including a battery control center
troubleshooting guide and recommend having a qualified service
technician or electrician do this repair.

Here is a link to the PDF file they sent along with the reply.

Battery Control Center Trouble Shooting Guide
__________________
GoBigGuy is offline   Reply With Quote
Old 03-23-2011, 07:20 AM   #10
Junior Member
 
Join Date: Jan 2011
Posts: 8
That's where mine must be also, it's in that black box behind the fuses. I was reading up on them and some have fuses, so it could be the fuse. Thanks for the help
__________________

__________________
ricklap is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Disconnect Switch By front Door mwadsworth Monaco Owner's Forum 15 02-12-2015 07:48 PM
Chassis battery disconnect switch wagonmaster2 Winnebago Industries Owner's Forum 7 08-17-2010 11:51 PM
Another Battery Disconnect Solenoid Question LewF Monaco Owner's Forum 2 09-02-2009 10:35 PM
Chassis Battery Disconnect While Parked javpop Monaco Owner's Forum 4 04-01-2009 09:36 PM
Battery Disconnect??? Auto Disconnecting??? MXDad93 Monaco Owner's Forum 12 03-18-2009 05:59 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.