Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-27-2012, 08:28 AM   #1
Junior Member
 
Join Date: Jul 2011
Posts: 1
Battery disconnect relay cycles on/off

The battery disconnect relay on my 02 Damon Escaper occasionally cycles on/off about every 15 seconds. Has anyone had this problem? My Intellitec BD1 display only shows a charge of 10.1. It cycles both with shore power and without.
__________________

__________________
dashmo01 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-27-2012, 08:37 AM   #2
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,085
Sounds like intermittent power to the +12v terminal on the relay.

Is 10.1 the voltage? If so, the batteries are dead for all practical purposes. Probably the charging system isn't working.
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 07-28-2012, 02:57 PM   #3
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 1,659
Check your GFI's because many converters are wired into that type of 120Vac circuit. And, check that your converter is getting 120V.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : http://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 07-28-2012, 09:27 PM   #4
Senior Member
 
mgscott4's Avatar
 
Workhorse Chassis Owner
Join Date: May 2009
Location: Kansas City, MO./Pollock, LA.
Posts: 1,549
Is your converter fan cycling?

On my Thor, Four Winds, 06 Hurricane, the interior lights would dim and bright about every 10 seconds. When they brightened, I could here the fan on the converter come on. Then when the lights dimmed, the fan would go off. Changed my converter. Fixed the problem.
__________________
06 Hurricane 34FT WH W20 Chassis 8.1L 132K, Steersafe, Koni Shocks, DIY Trac Bar, Tri-Metric 2025RV Battery Monitor, 4-6V Batteries, Scan Gauge 2, Crossfires, 735W Solar Morningstar MPPT-60, WG T4 In-Motion Sat, XM Radio, 07 Chevy Malibu Maxx Toad, Falcon 2, Brake Buddy, Escapee
mgscott4 is offline   Reply With Quote
Reply

Tags
battery



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.