Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-30-2014, 09:25 PM   #1
Member
 
meffrig's Avatar
 
Thor Owners Club
Forest River Owners Club
Join Date: Mar 2012
Location: Carrollton, Kentucky
Posts: 41
Can't figure it out!

I have a new 2014 Thor Windsport with a TV located in a compartment outside. While at home, I was doing my monthly generator check so I while I was running the generator, I turned on the outside TV. After letting it run for a 1/2 hour or so I turned off the generator. The outside TV went off when the generator was turned off and now it will not come back on. All the outlets both inside and outside, lights, inside TV's and everything else is working fine. I have checked all the breakers and the fuses. I have tried to get to where the TV is plugged in from the inside (behind a bathroom cabinet) and have taken the tv loose from the outside and can't get to where the power for the TV is coming from. Hopefully the outside TV isn't fried-have never had any problems with it before. Any advice would be appreciated.
__________________

__________________
meffrig is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-30-2014, 09:32 PM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,753
Its possible the outside TV needs 120 to operate and the inside TV's work off 12v from your batteries.
Did you try to see if you run your Gen again the TV comes on with Gen running?
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 04-30-2014, 09:46 PM   #3
Member
 
meffrig's Avatar
 
Thor Owners Club
Forest River Owners Club
Join Date: Mar 2012
Location: Carrollton, Kentucky
Posts: 41
I have tried that as well with no luck. I am plugged in here at home now to 110 and all TV's work except for the outside TV. The rest of my TV's have a tiny red light that shows they are getting power and the outside TV is not showing that red light. I have even changed the batteries in the remote. I am baffled.
__________________
meffrig is offline   Reply With Quote
Old 04-30-2014, 09:47 PM   #4
Member
 
stisdal's Avatar
 
Join Date: Feb 2014
Location: Following the mild weather! (USA)
Posts: 37
Some of these tv's will get scrambled when the power gets shut off, you are correct in trying to get to the plug and disconnect it for at least 10 minutes. (Allows capacitors to drain) then plug it in and try it...

Good luck!


Sent from my iPad using iRV2 - RV Forum
__________________
1998 Rexhall Aerbus (32') F53-460
stisdal is offline   Reply With Quote
Old 04-30-2014, 10:08 PM   #5
Senior Member
 
Bubba1's Avatar


 
Join Date: Jan 2008
Location: D/FW Texas
Posts: 448
Most likely that outside TV is plugged into a GFI plug, and was probably tripped with the gen was shut down. You may have an outside GFI plug that controls the TV plug. Check to see if you have a GFI plug tripped.
__________________
Mike & Debbie
2003 36' Monaco Cayman
2007 Saturn Vue "pusher"
Bubba1 is offline   Reply With Quote
Old 04-30-2014, 10:21 PM   #6
Member
 
meffrig's Avatar
 
Thor Owners Club
Forest River Owners Club
Join Date: Mar 2012
Location: Carrollton, Kentucky
Posts: 41
Problem solved. I went inside the coach and turned off the inverter, turned it back on, and the outside TV works! To say the least, troubleshooting can be bear sometimes! Thanks for the replies.
__________________
meffrig is offline   Reply With Quote
Old 05-01-2014, 01:10 AM   #7
Senior Member
 
JFXG's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: May 2012
Location: Today? Mercer, PA
Posts: 3,615
Just a bit of advice...... In future, shut stuff off before shutting off the gen. In theory everything, but the important things are the sensitive electronics.
__________________
John & Diane, Fulltimers. RVM103 NHSO
On the road since June '12 with Lincoln, the guard cat.
2002 Dutch Star 40, Freightliner, Cat 3126, 2004 Element
JFXG is offline   Reply With Quote
Old 05-01-2014, 01:32 AM   #8
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 5,902
Quote:
Originally Posted by JFXG View Post
Just a bit of advice...... In future, shut stuff off before shutting off the gen. In theory everything, but the important things are the sensitive electronics.

I agree!!

And don't run your generator when you are plugged into shore power.
Yes, you can do it but let's not push our luck.
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Arch Hoagland is offline   Reply With Quote
Old 05-01-2014, 04:21 PM   #9
Junior Member
 
FlaBoy's Avatar
 
Join Date: Nov 2013
Location: Ponte Vedra Beach, FL
Posts: 22
I also have a new Thor Windsport and my inside TVs go off if I turn off the inverter remote control switch (green LED light is off). So, not unique to outside TV.
__________________
Steve & Rita Goldman
2015 Thor Tuscany XTE 36MQ with Yellow Lab Marley
Out of Ponte Vedra Beach, FL Toad- 2015 Jeep Grand Cherokee 4X4
FlaBoy is offline   Reply With Quote
Old 05-01-2014, 06:54 PM   #10
Member
 
meffrig's Avatar
 
Thor Owners Club
Forest River Owners Club
Join Date: Mar 2012
Location: Carrollton, Kentucky
Posts: 41
Quote:
Originally Posted by JFXG View Post
Just a bit of advice...... In future, shut stuff off before shutting off the gen. In theory everything, but the important things are the sensitive electronics.
Will do. Thanks for all the replies!
__________________

__________________
meffrig is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading 5,000# receiver to 10,000#? Options? palehorse89 Spartan Motorhome Chassis Forum 52 07-14-2014 06:56 PM
12v Light Switch ProjectPro Tiffin Motorhomes Owners Forum 8 03-31-2014 07:53 AM
Proud owner off a 2008 Lexington gboyle Class C Motorhome Discussions 5 02-28-2014 09:25 PM
Heat/AC control questions bobcovey Monaco Owner's Forum 4 12-22-2013 12:48 PM
400-450 Cummins in a Monaco a mystery ? darstar Monaco Owner's Forum 19 09-13-2013 08:49 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.