Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 12-29-2013, 09:40 PM   #1
Junior Member
Join Date: Jul 2013
Posts: 6
Carefree Awning retracts very slow

My carefree awning has been slow retracting and today it rolled up but won't go into the tube.

Jhmclennan is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-29-2013, 09:55 PM   #2
Senior Member
sdennislee's Avatar

Monaco Owners Club
Winnebago Owners Club
Join Date: Sep 2011
Posts: 6,360
Check voltage to the motor and lubrication of the arms in the the track.

When mine became slow, I found the electrical connection had corroded form water intrusion. Voltage to the motor was below 10 volts.

Clean the connection and sealed it.

I also find that lubing the track the arms slide in a couple times a year helps keep the movement smooth and quick.

US Navy Vet, Liberty Tree Member of Oath Keepers, NRA & VFW Life Member, Alaska EMT.
2009 Safari Cheetah 40 SKQ
2009 Winnebago Chalet 231CR
sdennislee is offline   Reply With Quote
Old 12-29-2013, 10:37 PM   #3
Senior Member
Join Date: Apr 2012
Posts: 1,493
Ditto re the connection. I had corrosion on an RV Awning motor connection right at the plug where it connected to the RV exterior and the motor was very slow. Voltage was about 11v at the motor. Cleaned it up and put caulking on it and all was fine.
Libero is online now   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:40 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.