Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2015, 03:52 PM   #1
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2014
Location: Central Florida..
Posts: 238
Charging question... Possible issue...

Well moved the Coach( 2005 newmar Mountain aire) in preparation of a little vacation... It started fine ( parked for 3 month)but noticed that the alternator didn't seem to be charging like I had noticed in the past... I usually scan the gauges..and the alternator stays around 13.1 and 13.9.. But today it was a steady 12 volts.. Turned everything electrical on to create a draw.. Would drop to 11.9 then back up to 12.0.. After about 10 minutes decided to check the belt.. Opened the hatch everything looked good.. Went back to the gauges everything was back to normal 13.9... Never noticed this happen before..I keep the rig plugged in but keep the house power switch off...( I'm told this doesn't allow the engine batteries to charge)..I also have a 30volt solar panel on the roof( replaced the factory installed engine battery maintainer)..

Taking a 2000mile trip...wondering if his could an issue..

Thoughts, opinions..

Thank you
__________________

__________________
2004 Mountain Aire 4018
Speedjester is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-03-2015, 04:15 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,219
If you leave it plugged in, why do you turn off the house batteries? If it's charging properly now, I'd check the battery and ground connections, removing and cleaning each one.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 10-03-2015, 04:46 PM   #3
Senior Member
 
dennis45's Avatar


 
Join Date: Jun 2012
Location: BC
Posts: 6,452
I too question why you turn off the house power. Mine is plugged in 24/7 and never use the disconnects.
If you converter is maintains 13.6 - 13.8 VDC you have nothing to worry about. Just check the water levels in the batteries every 3-4 months and top up as required.
__________________
Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Old 10-03-2015, 06:04 PM   #4
Senior Member
 
Join Date: Jan 2013
Posts: 370
Not sure which chassis you have but the alternator charging you describe is not that unusual for us with a Freight liner chassis.
Reads around 12 volts and may fluctuate a little after first starting.
Typically clears up after a few minutes running.
__________________
Dan
2014 Berkshire 390RB
dan-nickie is offline   Reply With Quote
Old 10-07-2015, 07:27 AM   #5
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2014
Location: Central Florida..
Posts: 238
I have a spartan chassis... Started it twice.. Same issue doesn't seem like its charging stays a steady 11.8-12.00... But after a few minutes it reading correctly.. 13.90... It could have been doing his all along..but just noticed it after pulling the coach out of storage..
__________________
2004 Mountain Aire 4018
Speedjester is offline   Reply With Quote
Old 10-07-2015, 07:30 AM   #6
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2014
Location: Central Florida..
Posts: 238
My house batteries charge regardless.. if the salesman switch is on or off...my chassis batteries charge from the solar panel( when switch is off... And from inverter when switch is on..
__________________
2004 Mountain Aire 4018
Speedjester is offline   Reply With Quote
Old 10-07-2015, 10:11 AM   #7
Senior Member
 
Join Date: Aug 2010
Posts: 455
Grid Heater??
__________________
Stik
Full Timing since 2005
09 Journey 34Y, 2015 Grand Cherokee Toad
stik is offline   Reply With Quote
Old 10-07-2015, 11:45 AM   #8
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,219
Quote:
Originally Posted by stik View Post
Grid Heater??
That could be why low charging voltage starting up, but the OP is in Florida, is the grid heater on every start or only on cold days and cold engine?
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 10-07-2015, 07:04 PM   #9
Senior Member
 
Cat320's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: Mar 2011
Posts: 4,749
Quote:
Originally Posted by Speedjester View Post
...my chassis batteries charge from the solar panel( when switch is off... And from inverter when switch is on...
Do you mean the batteries charge from the charger part of the inverter/charger? The inverter charges nothing, it converts 12v to AC power.
__________________

__________________
2014 American Eagle 45T
DD 500
Pulling a Honda CRV
Cat320 is offline   Reply With Quote
Reply

Tags
charging



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Key Maintenance/Repair Issue Question GGW Country Coach Owners Forum 15 03-20-2015 11:18 PM
2011 Thor Hurricane Charging Issue Joe Garner Thor Industries Owner's Forum 2 11-22-2014 07:15 PM
Chassis Battery Issue TXBart Entegra Owner's Forum 35 11-03-2014 04:48 PM
Battering charging question... dtpatt21 Workhorse and Chevrolet Chassis Motorhome Forum 3 06-28-2014 02:06 AM
Question About Chassis Battery Charging on Shore Power TandCplusRV RV Systems & Appliances 15 02-05-2014 11:57 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.