Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-21-2015, 03:03 PM   #1
Senior Member
DraginRat's Avatar
Join Date: Dec 2014
Location: San Antonio, Texas
Posts: 113
Chassis A/C blower not working

We have a 1990 Holiday Rambler on a 1990 P-30 chassis.

The A/C blower fan does not work. I am not sure the heater is working, but I can hear the A/C clutch engage when I turn it on, but the fan never does turn on. I checked the controls and everything seems to be working. The push on connecter for the fan speed control has four wires. One is ground, the other three have battery.

There is one red wire attached to the opposite end of the control panel from the fan switch that has been cut, and has neither ground or battery on it. I tried hooking it to ground, then battery with no effect.

I have both the 1990 chassis manual and the coach manual, but neither has much on the A/C wiring.

Anyone that has any insight, I would certainly appreciate your help.

Ken Gasbarri

Be Of Good Cheer!!!
DraginRat is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-21-2015, 07:33 PM   #2
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,950
New problem , or a new to you coach?
Can you access the fan motor and check for power there?
The system should have a resistor block , that reduces the voltage supplied to the motor , and so varies the speed. This resistor is usually mounted close to the motor in the fan airflow to cool the resistor.
As in this photo. Resistor is the part with the wiring attached.
Attached Thumbnails
Click image for larger version

Name:	IMG_0230 (360x640).jpg
Views:	27
Size:	162.0 KB
ID:	100787  

99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-21-2015, 07:41 PM   #3
Registered User
Tiffin Owners Club
Join Date: Mar 2015
Location: Southern NM
Posts: 909
The A/C and Heater blower are the same.

Usually if the resistor is bad, the high speed will still work and the low med etc will not.

Did you check the fuse? if its good, I would disconnect the harness from the motor and check for 12v at the connector, if you have 12v then blower motor is bad.
Just re read your post, if you have 12v at the wire, then look at your blower motor being the problem.

If no voltage at the connector, check dash control
CJ7365 is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie needs Chassis A/C Help...pleses RobRoy Monaco Owner's Forum 10 07-15-2015 06:49 PM
Workhorse to Re-enter RV Chassis Market tropical36 Class A Motorhome Discussions 1 05-22-2015 02:05 PM
Chassis A/C gt350ed Vintage RV's 10 08-16-2014 12:38 PM
Coach A/C vs. Cab A/C, Better fuel economy... fact or fiction? Mark Spears Class C Motorhome Discussions 13 08-15-2014 04:43 AM
Intellitec remote start of generator, front A/C & rear A/C not working in bedroom rlmorrison Gulf Stream Owner's Forum 1 08-14-2014 04:04 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:21 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.