Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 06-27-2015, 11:50 AM   #15
Senior Member
dennis45's Avatar

Join Date: Jun 2012
Location: BC
Posts: 4,690
Originally Posted by Dutch Star Don View Post
"dennis45"....I had a Cummins ISL in a 2005 Diplomat that 77K without a blip. I buy the new Dutch Star on a Freightliner chassis and on the first trip I get a CEL. Just as I got home, it had cycled enough that it went out. Next trip I get it again. This time I took it to Cummins and see that it's an over temp code of the EGR. After several hours of resetting and tripping other codes, they say it's fixed. Now I'm getting gun shy.

After the second repair I read where many wait until all of their gauges sweep before starting. I started this practice and no more lights. A few months later we were leaving Yosemite and had to stop along the side of the road to wait for the daughter in her RV. When I saw them coming I rushed to start the coach, didn't wait for the gauges to sweep and sure enough, the CEL came on. It went off a few minutes later. The theory about waiting for the computer makes sense. My last Cummins didn't have all the extra electronics related to emissions, such as DEF sytsems.
My old ECM is probably like me, doesn't like to be rushed. I guess we will see if this does the trick.

Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-13-2015, 06:57 PM   #16
Junior Member
Ducks yet's Avatar

Join Date: Apr 2013
Location: United States
Posts: 22
Any one had the engine Amber light come on I ran a diagnostic test a fault code SPN 1632 FMI 20 came up.
The coach a Thor Palazzo with a 300 hp cummins engine runs normal pulled off for the night in Savannah Georgia.

Best Wishes.
Donald F Grant
Ducks yet is offline   Reply With Quote
Old 09-16-2015, 04:16 PM   #17
Junior Member
Join Date: Oct 2014
Posts: 7
CEL test harness for OBD 2

I have a 98 Rexhall Aerbus with Ford 460. I have an OBD 2 tester but I cannot locate the harness to plug into in order to get the codes why my CEL comes on. Keep in mind I am not a mechanically inclined person. I have checked all over the steering column, all over under the dash on driver and passenger side. If anyone could provide me with detailed info or even a picture would be awesome. I am a retired Sailor and total and permanently disabled so crawling around under the dash gets a little uncomfortable. Thank you in advance.
Elteec is offline   Reply With Quote
Old 09-16-2015, 04:24 PM   #18
Senior Member
eddieelk's Avatar
Fleetwood Owners Club
Join Date: May 2011
Location: summer-Cuba Mo./winter Weslaco TX.
Posts: 309
Ford 460's aren't OBD 2 Oreillys has the required Ford OBD 1 for $35.00. The plugin is way up front on the left side above the a/c compressor. I bought the extension cable to make things easier. Eddie Elk.

1998 Pace Arrow Vision 36' w/460, '98 Saturn SW2, FMCA #388823, Gateway Getaways RV Club
eddieelk is offline   Reply With Quote

check engine light, engine, light

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light reset? Roaddoggie Caterpillar Engine Forum 3 02-04-2015 05:39 PM
High Water Temp & Check Engine light on Al Childress Monaco Owner's Forum 5 11-17-2014 04:21 PM
Water in fuel light and check engine light Donny Q Cummins Engines 4 09-24-2014 09:44 AM
False Check Engine light on C7?? Freightguy Caterpillar Engine Forum 26 09-15-2014 09:53 AM
First Big Trip - Check Engine Light Dutch Star Don Newmar Owner's Forum 38 07-17-2014 07:46 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:58 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.