Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-25-2015, 06:15 PM   #1
Junior Member
 
Join Date: Apr 2006
Location: beaumont,tx
Posts: 26
check engine light

my check engine light has come on. my coach is running great, checked oil, water and all is great, what could cause it to come on
__________________

__________________
max77713 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-25-2015, 06:24 PM   #2
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 4,517
What kinda coach? I really doesn't matter the only way to find out is hook it up to a computer reader anything else would be guesses.
__________________

__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-25-2015, 06:37 PM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 9,907
He has a 2000 Newmar Mountian Aire. 40 ft.

It's in his info.
__________________
twinboat is offline   Reply With Quote
Old 06-25-2015, 06:45 PM   #4
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 4,597
Do you have the ability to get codes off the engine. Could be just about anything, really no way to tell without codes.
__________________
Jim J
2002 Monaco Windsor 38 PKD
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 06-25-2015, 06:58 PM   #5
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 4,517
Quote:
Originally Posted by twinboat View Post
He has a 2000 Newmar Mountian Aire. 40 ft.

It's in his info.
Thank you but not very helpful.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-25-2015, 07:52 PM   #6
Senior Member
 
dennis45's Avatar


 
Join Date: Jun 2012
Location: BC
Posts: 6,466
Quote:
Originally Posted by max77713 View Post
my check engine light has come on. my coach is running great, checked oil, water and all is great, what could cause it to come on
Welcome to the forum. Since you are new, I'll give you a tip, go into user CP and edit signature and put in all the information on your coach/toad etc. then when you post with a question, folks will know what you have and be able to respond with better information that is pertinent to your coach.

__________________
Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Old 06-25-2015, 08:03 PM   #7
Senior Member
 
dennis45's Avatar


 
Join Date: Jun 2012
Location: BC
Posts: 6,466
There has been a ton of discussion on the subject of CEL. I have bee plagued with this problem since I owned this coach and I'm not alone. I had mine into Cummins and they could not see any fault codes in the life of the engine. They did not have an answer.
A couple of times I thought I had it licked only to have a check engine light come on again a few thousand miles later.
On the bright side, when it comes on, it only de rates the engine slightly so I keep on going (with that annoying buzzer blaring) and find a spot that is safe to pull over. Shut the engine off, let it sit for a couple minutes, restart and off we go. Might not see it again for thousands of miles. Or could be a few hundred.
One thing I have read lately, and I may be guilty of, is not waiting for the WAIT light to go out on start up. I have read this will upset the ECM and it will cause a CEL at some point. That's my new mission, so we will see.

Hope this helps shed some light on your problem. You're not alone.
__________________
Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Old 06-25-2015, 08:29 PM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,971
[QUOTE=max77713;2620562]my check engine light has come on. my coach is running great, checked oil, water and all is great, what could cause it to come on[/QUOTE



As others have mentioned , there are over a dozen possible causes for the check engine light , some will cause the engine to de-rate to as low as 100 HP just to allow you to get off the road, others will just keep the light on, telling you , there is maintenance required. SOME will shut the engine off!
Without the active code , and info on the engine type, Cat ? Cummins ? and size, the members here in the forums are just as in the dark as you are.

Many RV owners , have installed , Scan Gauge or Silverleaf on dash displays to allow them to get the codes and erase them after the cause has been dealt with.

SilverLeaf Electronics, Inc. | Knowledge is Horsepower?...

ScanGaugeD - Advanced J1939 & J1708 compatible Vehicle Monitor for Diesel Pusher Vehicles : Linear Logic
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-26-2015, 07:10 AM   #9
Senior Member
 
BadBoy's Avatar
 
Join Date: Jun 2010
Location: Kingston, Ontario
Posts: 135
Check your gas cap is on tight.

I had a similar problem and discovered this simple fix. Hoping it's as simple for you!
__________________
99 Fleetwood Southwind 32V (Class-A)

Prior: 97 Ford Dutchman (31 Ft, Class-C)
BadBoy is offline   Reply With Quote
Old 06-26-2015, 09:09 AM   #10
Senior Member
 
dennis45's Avatar


 
Join Date: Jun 2012
Location: BC
Posts: 6,466
Quote:
Originally Posted by BadBoy View Post
Check your gas cap is on tight.

I had a similar problem and discovered this simple fix. Hoping it's as simple for you!

Thanks for that one, I actually replaced both caps and guess what, a couple thousand miles later, CEL. NO CODES.
__________________
Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Old 06-26-2015, 09:56 AM   #11
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,971
Quote:
Originally Posted by dennis45 View Post
Thanks for that one, I actually replaced both caps and guess what, a couple thousand miles later, CEL. NO CODES.

Wouldn't be your issue, diesel engines don't run the same, evaporative emissions system as gassers, and so no monitoring, of the fuel tank, that would cause a CEL.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-26-2015, 10:12 AM   #12
Senior Member
 
dennis45's Avatar


 
Join Date: Jun 2012
Location: BC
Posts: 6,466
Quote:
Originally Posted by Skip426 View Post
Wouldn't be your issue, diesel engines don't run the same, evaporative emissions system as gassers, and so no monitoring, of the fuel tank, that would cause a CEL.
Absolutely, I changed the caps because the ratchet on one broke so replaced them both. I was not expecting any change to my CEL issue.

That said, I'm still convinced it is an intermittent electrical issue that cause a blip to the ECM but not enough to register a code. Also thinking along the lines of the Crank/Cam Position Sensor. One of these days when I get a roundtoit, I'm going to remove the pick up and see if there is any metal debris on the end. That will take a little a little motivation.
__________________
Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Old 06-27-2015, 11:51 AM   #13
Senior Member
 
bobmac's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Mar 2008
Location: Southern Ontario
Posts: 925
My experience with my Cummins ISB on a Freightliner chassis is that the LBCU does not capture all engine codes unless they have become a solid trouble that affects engine performance. By the time you find them on the LBCU, the engine performance will likely be affected. I talked to the Freightliner help line and they confirmed what I had observed.
I purchased a Scangauge-D after good experience with the one in the car. I recently noticed that I was getting codes on startup that the ScanGauge detected but were not recorded in the LBCU. I recently detected a code for the turbo actuator that would flash the CEL for a second or so but was only captured by the ScanGauge. After receiving several codes, I took the coach to Cummins and after troubleshooting, the turbo had to be replaced. The engine reports an actuator issue in advance of full turbo failure. The ScanGauge saved me several thousand of dollars as my 5 year warranty is expiring next month.
I also had the same code experience before my EGR valve failed but did not act until it stuck open. My conclusion is that if you are seeing the CEL, find out what is causing it - don't ignore it and consider getting a code reader so you know what is being reported. In my case, it has more than paid for itself and I haven't been left stranded on the side of a highway.
__________________
Bob
09 Journey 39Z
Southern Ontario
bobmac is offline   Reply With Quote
Old 06-27-2015, 12:43 PM   #14
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 9,304
"dennis45"....I had a Cummins ISL in a 2005 Diplomat that went 77K without a blip. I buy the new Dutch Star on a Freightliner chassis and on the first trip I get a CEL. Just as I got home, it had cycled enough that it went out. Next trip I get it again. This time I took it to Cummins and see that it's an over temp code of the EGR. After several hours of resetting and tripping other codes, they say it's fixed. Now I'm getting gun shy.

After the second repair I read where many wait until all of their gauges sweep before starting. I started this practice and no more lights. A few months later we were leaving Yosemite and had to stop along the side of the road to wait for the daughter in her RV. When I saw them coming I rushed to start the coach, didn't wait for the gauges to sweep and sure enough, the CEL came on. It went off a few minutes later. The theory about waiting for the computer makes sense. My last Cummins didn't have all the extra electronics related to emissions, such as DEF systems. I'm sure the time frame for the computer to run all of it's checks is longer than before.
__________________

__________________
Don & Mary
2014 Newmar Dutch Star - All Electric - 450 ISL
2016 GMC Canyon 4WD Crew Cab
Dutch Star Don is offline   Reply With Quote
Reply

Tags
check engine light, engine, light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light reset? Roaddoggie Caterpillar Engine Forum 3 02-04-2015 06:39 PM
High Water Temp & Check Engine light on Al Childress Monaco Owner's Forum 5 11-17-2014 05:21 PM
Water in fuel light and check engine light Donny Q Cummins Engines 4 09-24-2014 10:44 AM
False Check Engine light on C7?? Freightguy Caterpillar Engine Forum 26 09-15-2014 10:53 AM
First Big Trip - Check Engine Light Dutch Star Don Newmar Owner's Forum 38 07-17-2014 08:46 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.