RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-11-2019, 08:26 AM   #1
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 796
Check engine light and engine brake

Just took the coach out for a drive for exercise. Fired up and ran well until I tried the engine brake. Then I got a check engine light. Had a loss of power and some severe stutter in the engine. The check engine light went off briefly and came back on a few times. Stopped at a truck stop and the check engine light went away. Started back home and had low power coming up the ramp to merge. Showed about 32 psi of boost. After a bit, the power came up and the engine ran fine the rest of the way home. It did not seem that the engine brake was functioning properly, but the engine developed a lot of horsepower and ran fine. Anyone have any opinions on what might be going on with my engine? It is a Cummins 400 ISL.
__________________

__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-11-2019, 08:40 AM   #2
Junior Member
 
Rsb3's Avatar
 
Join Date: Dec 2016
Posts: 12
Just my thought with no other info, because I had similar symptoms 2years ago. Especially the low power plus check engine, ended up being the EGR valve.
__________________

Rsb3 is offline   Reply With Quote
Old 02-11-2019, 11:55 AM   #3
Senior Member
 
Join Date: Nov 2017
Location: Citra, Florida
Posts: 1,381
The check engine light is an emissions issue, the erratic performance could indicate a loose part, such as an O2 Sensor. Or, as mentioned above, the EGR valve.
Might be a good place to start.
__________________
Good Luck and keep us posted please. "Q"
1999 Newmar, Mountain Aire 3768, V-10, CAI, Headers.
"Spending our kids inheritance one trip at a time"
Quincy is offline   Reply With Quote
Old 02-11-2019, 11:58 AM   #4
Senior Member
 
Join Date: Nov 2017
Location: Citra, Florida
Posts: 1,381
By the way, "exercising" the coach, weather gas or diesel is not necessary and can cause more problems than it solves. Especially if you are not going out for at least thirty minutes of "on the road" driving.
__________________
Good Luck and keep us posted please. "Q"
1999 Newmar, Mountain Aire 3768, V-10, CAI, Headers.
"Spending our kids inheritance one trip at a time"
Quincy is offline   Reply With Quote
Old 02-11-2019, 12:08 PM   #5
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 796
Actually, I needed to start the coach to relocate it at my home and did not want to just start for a few minutes and shut down. Had it on the road for about 30 minutes and got temps up to normal operating range. Planned a longer trip until the CEL came on. Normally, Elvira sits until ready to be used.
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Old 06-18-2019, 07:58 PM   #6
Member
 
IndyHntr's Avatar


 
Fleetwood Owners Club
Join Date: Jun 2012
Location: Hope, IN
Posts: 52
Having same issue, thanks for all the info on this thread and I found another with info. Check Engine light always comes on when Engine Brake engages. I am guessing fluid surges forward and trips sensor. So will check all fluids. The fuel filter is brand new, first trip. So counting that out. Will let you know if I find anything.
IndyHntr is offline   Reply With Quote
Old 06-20-2019, 07:35 AM   #7
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 796
Had mine checked out and it was a code for low fuel pressure. Repair shop was not able to duplicate the code again. They changed the fuel filters and the ones they removed were clean.They talked with Cummins could not reach a solution. They drove it about 50 miles running hard up grades and down and could not get it to happen again. Since then, we have clocked about 1600 miles with no problems. Still don't know what happened. It will probably come back around to bite someday.
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Old 11-18-2019, 10:55 AM   #8
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 796
Well, CEL is back. Last two short trips, CEL would come on a few minutes go out, come back on, go out for about 30 minutes or so, then it would go out and stay off until we got where we were going. Looks like it is back to the shop time.
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Old 11-18-2019, 12:09 PM   #9
Senior Member
 
nathaniel's Avatar
 
Join Date: Nov 2017
Posts: 293
Have you checked your antifreeze holding tank. There is little room for error on the low level sensor and it will put you in limp mode thinking your low on antifreeze regardless of water temperature.
__________________
2009 Gulfstream Caribean
40 ft trio
350 Cummins
nathaniel is offline   Reply With Quote
Old 11-18-2019, 12:19 PM   #10
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 796
Yes, the bubble is right where it should be in the site glass. No limp mode, just a CEL and a mild power loss. Seems to be a low fuel pressure code based on the shop check back in February. They talked with Cummins and no one could get it to happen again or determine a cause.
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Old 11-18-2019, 04:59 PM   #11
Member
 
Join Date: Jul 2017
Posts: 98
Next time it happens, loosen up the fuel cap and listen for a Vacuum. Than try running it with the cap loose, it sounds like the vent to the fuel tank could be partially plugged.
Caliber is offline   Reply With Quote
Old 11-19-2019, 02:22 PM   #12
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 796
Thanks caliber. It is worth a try.
__________________

__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Reply

Tags
brake, check engine light, engine, light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amber Engine Light ISL8.9, 450hp. Not check engine light Carefree Cummins Engines 7 05-27-2018 11:50 PM
05 Holiday Rambler Neptune Check engine, Check Trans Light bob ferris Monaco Owner's Forum 1 07-21-2016 11:35 AM
Check Engine Light and Jake Brake CWinLV Newmar Owner's Forum 5 07-09-2015 06:37 PM
Water in fuel light and check engine light Donny Q Cummins Engines 4 09-24-2014 10:44 AM
Ford Transmission Control Indicator Light and check engine light HKB MH-General Discussions & Problems 4 05-28-2007 04:23 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×