Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-13-2015, 05:12 PM   #1
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 202
Check Engine light C9 Cat

I posted this on the Beaver Forum and wanted to repeat here if anyone has experience with this engine.
On our way home from Florida we got the dreaded "check engine" light about 60 miles from home.The coach is running good and all fluids are good ,temps are good, but the code on the LCD display shows an SPN 3474 FMI 31 code in the diagnostic readout.
The Cat Hotline says the code is a failure to ignite code and I probably have an issue with the ARD and/or regeneration function of the C9 engine I have.
I scheduled an app with the local Caterpillar shop for Wed and I was just trying to find out as much about this issue as I could before I get there.
I know there have been issues with this engine and the turbo and ARD head were replaced in June 2013.
What experience have others had lately??
Anything that might help me at the repair shop??
Thanks,
Dan
Modify message
Report to moderator 38.65.252.100
Dan and Kris Murphy
2009 Beaver Contessa
Cat C-9 425hp
2013 Ford Cmax
__________________

__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-13-2015, 09:25 PM   #2
Member
 
Join Date: May 2013
Posts: 79
Send a message via ICQ to Waterview202
I had the check engine light problem with my 2009 beaver. Cat had to do a computer update, to correct the problem
__________________

__________________
2009 beaver contessa 425hp. C9 cat,2012 jeep wangler ,missouri
Waterview202 is offline   Reply With Quote
Old 04-14-2015, 07:59 AM   #3
Senior Member
 
tbfirm's Avatar
 
Monaco Owners Club
Join Date: Dec 2009
Posts: 138
Dan

I've had the failure to ignite issue as an ongoing problem also. Had the ARD head changed as well as connector/filters feeding fuel to the ard head. It continues to throw the failure to ignite code. Stopped at a Cat Dealer in Ocala two weeks ago and had them do a Manuel regeneration and clear the code again
The one new thing they came up with was that there is a box on the diesel particulate filter (DPF) with 2 temperature sensors. They say there is a possibility that this could be the problem because the ECU showed that there were erratic temperature readings the last time it threw the code. In further discussion with the tech he stated that it might also be just loose or bad wiring from the temp sensors to the ECU. The reasoning for that was that it performs a regen on the shop floor just fine with no erratic temp readings but bouncing down the highway it showed erratic readings.My next move is to check the wiring and connections from the DPF temp sensors to the ECU. A
Personally I think the problem here is bad engineering and CAT doesn't have a solution.
Please let us know how you make out
__________________
tbfirm is offline   Reply With Quote
Old 04-27-2015, 08:39 AM   #4
Senior Member
 
tbfirm's Avatar
 
Monaco Owners Club
Join Date: Dec 2009
Posts: 138
Dan,
Please provide an update
__________________
tbfirm is offline   Reply With Quote
Old 08-23-2015, 05:16 PM   #5
Senior Member
 
DD788Snipe's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2013
Location: Apple Valley CA
Posts: 914
Quote:
Originally Posted by tbfirm View Post
Dan,
Please provide an update
Dittos Dan. I have friends that just bought a 2009 Safari 42 PAQ coach also and are having the same problem. They are at CAT in Roseburg as I type and this is the second shop to look at it. Need answers!!!!!
__________________

Craig & Carolyn Roberts Apple Valley, CA
2006 Newmar 3910 KSDP 400 ISL Cummins Spartan Mountian Master Chassis
Toad: 2017 GMC Canyon 4X4 Crewcab
DD788Snipe is offline   Reply With Quote
Old 08-30-2015, 03:14 PM   #6
Senior Member
 
DD788Snipe's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2013
Location: Apple Valley CA
Posts: 914
James said they had it install a new ARD. The orginal was carbonic up. If you own a CAT with a DPF, don't let it idle for and length of time. New ARD + labor $1000.
__________________

Craig & Carolyn Roberts Apple Valley, CA
2006 Newmar 3910 KSDP 400 ISL Cummins Spartan Mountian Master Chassis
Toad: 2017 GMC Canyon 4X4 Crewcab
DD788Snipe is offline   Reply With Quote
Old 09-12-2015, 01:13 AM   #7
Junior Member
 
Join Date: Oct 2014
Posts: 7
Obd 2 harness locatio

I am sorry I don't have an answer for you. But maybe you or someone could help me.

I have 98 rexhall Aerbus with the Ford 460. My check engine light came on but everything runs great and all gauges read normal. I have driven it like this for over 1800 miles. Took it to two nationally recognized parts stores and no one can locate the plug in to check the codes to identified issues. Everyone says it is on or near the steering column. It isn't there or anywhere under the dash. I bought a tester but cannot locate the plug anywhere. Trust me, o have spent hours to locate the harness. Can anyone tell me exactly where to hook up the Obd 2 test meter? I am to the point I believe not one exists. Ideas?
__________________
Elteec is offline   Reply With Quote
Old 09-16-2015, 01:35 PM   #8
Senior Member
 
DD788Snipe's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2013
Location: Apple Valley CA
Posts: 914
Quote:
Originally Posted by Elteec View Post
I am sorry I don't have an answer for you. But maybe you or someone could help me.

I have 98 rexhall Aerbus with the Ford 460. My check engine light came on but everything runs great and all gauges read normal. I have driven it like this for over 1800 miles. Took it to two nationally recognized parts stores and no one can locate the plug in to check the codes to identified issues. Everyone says it is on or near the steering column. It isn't there or anywhere under the dash. I bought a tester but cannot locate the plug anywhere. Trust me, o have spent hours to locate the harness. Can anyone tell me exactly where to hook up the Obd 2 test meter? I am to the point I believe not one exists. Ideas?
You need to move this to the Ford owners forum to get the answers your looking for.
__________________

__________________

Craig & Carolyn Roberts Apple Valley, CA
2006 Newmar 3910 KSDP 400 ISL Cummins Spartan Mountian Master Chassis
Toad: 2017 GMC Canyon 4X4 Crewcab
DD788Snipe is offline   Reply With Quote
Reply

Tags
cat, check engine light, engine, light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine light came on Dale & Patti National RV Owner's Forum 1 02-01-2015 08:41 AM
Reccurring check engine light rufusfruge Cummins Engines 7 07-08-2014 09:12 AM
Check Engine Light DennyNissley Workhorse and Chevrolet Chassis Motorhome Forum 18 06-01-2014 05:52 PM
Check engine light questions RClifton Fleetwood Products Owner's Forum 5 05-20-2014 12:12 PM
2006 Fleetwood Expedition - Check Engine Light CurrentBoy Class A Motorhome Discussions 3 05-08-2014 04:00 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.